mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:25:20 +02:00
6989b4a9bc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16635 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
895 B
Diff
27 lines
895 B
Diff
--- a/drivers/video/display/Kconfig
|
|
+++ b/drivers/video/display/Kconfig
|
|
@@ -21,4 +21,15 @@ config DISPLAY_SUPPORT
|
|
comment "Display hardware drivers"
|
|
depends on DISPLAY_SUPPORT
|
|
|
|
+config DISPLAY_JBT6K74
|
|
+ tristate "TPO JBT6K74-AS TFT display ASIC control interface"
|
|
+ depends on SPI_MASTER && SYSFS && LCD_CLASS_DEVICE
|
|
+ help
|
|
+ SPI driver for the control interface of TFT panels containing
|
|
+ the TPO JBT6K74-AS controller ASIC, such as the TPO TD028TTEC1
|
|
+ TFT diplay module used in the Openmoko Freerunner GSM phone.
|
|
+
|
|
+ The control interface is required for display operation, as it
|
|
+ controls power management, display timing and gamma calibration.
|
|
+
|
|
endmenu
|
|
--- a/drivers/video/display/Makefile
|
|
+++ b/drivers/video/display/Makefile
|
|
@@ -3,4 +3,5 @@
|
|
display-objs := display-sysfs.o
|
|
|
|
obj-$(CONFIG_DISPLAY_SUPPORT) += display.o
|
|
+obj-$(CONFIG_DISPLAY_JBT6K74) += jbt6k74.o
|
|
|