mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:25:20 +02:00
a210854b74
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16048 3c298f89-4303-0410-b956-a3cf2f4a3e73
26 lines
897 B
Diff
26 lines
897 B
Diff
--- a/drivers/input/misc/Kconfig
|
|
+++ b/drivers/input/misc/Kconfig
|
|
@@ -220,6 +220,15 @@ config HP_SDC_RTC
|
|
Say Y here if you want to support the built-in real time clock
|
|
of the HP SDC controller.
|
|
|
|
+config INPUT_LIS302DL
|
|
+ tristate "STmicro LIS302DL 3-axis accelerometer"
|
|
+ depends on SPI_MASTER
|
|
+ help
|
|
+ SPI driver for the STmicro LIS302DL 3-axis accelerometer.
|
|
+
|
|
+ The userspece interface is a 3-axis (X/Y/Z) relative movement
|
|
+ Linux input device, reporting REL_[XYZ] events.
|
|
+
|
|
config INPUT_PCF50633_PMU
|
|
tristate "PCF50633 PMU events"
|
|
depends on MFD_PCF50633
|
|
--- a/drivers/input/misc/Makefile
|
|
+++ b/drivers/input/misc/Makefile
|
|
@@ -25,3 +25,4 @@ obj-$(CONFIG_INPUT_UINPUT) += uinput.o
|
|
obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
|
|
obj-$(CONFIG_INPUT_YEALINK) += yealink.o
|
|
obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
|
|
+obj-$(CONFIG_INPUT_LIS302DL) += lis302dl.o
|