1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 08:49:19 +03:00
openwrt-xburst/target/linux/rb532/patches/510-rb500_led.patch
florian 9dd1cc458f Upgrade rb532 to .23, provide generic GPIO API to this board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10171 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-01-11 10:42:06 +00:00

28 lines
1.1 KiB
Diff

diff -urN linux-2.6.23.12/drivers/leds/Kconfig linux-2.6.23.12.new/drivers/leds/Kconfig
--- linux-2.6.23.12/drivers/leds/Kconfig 2007-12-18 22:55:57.000000000 +0100
+++ linux-2.6.23.12.new/drivers/leds/Kconfig 2008-01-11 09:01:19.000000000 +0100
@@ -101,6 +101,12 @@
outputs. To be useful the particular board must have LEDs
and they must be connected to the GPIO lines.
+config LEDS_RB500
+ tristate "LED Support for RB5xx boards"
+ depends LEDS_CLASS && MIKROTIK_RB500
+ help
+ This option enables support for the yellow user LED on RB5xx boards.
+
comment "LED Triggers"
config LEDS_TRIGGERS
diff -urN linux-2.6.23.12/drivers/leds/Makefile linux-2.6.23.12.new/drivers/leds/Makefile
--- linux-2.6.23.12/drivers/leds/Makefile 2007-12-18 22:55:57.000000000 +0100
+++ linux-2.6.23.12.new/drivers/leds/Makefile 2008-01-11 09:00:49.000000000 +0100
@@ -17,6 +17,7 @@
obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
+obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
# LED Triggers
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o