mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:38:26 +02:00
da1bd2aad6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
973 B
Diff
27 lines
973 B
Diff
--- a/drivers/mtd/maps/Kconfig
|
|
+++ b/drivers/mtd/maps/Kconfig
|
|
@@ -260,6 +260,13 @@ config MTD_BCM963XX
|
|
Support for parsing CFE image tag and creating MTD partitions on
|
|
Broadcom BCM63xx boards.
|
|
|
|
+config MTD_AR91XX_FLASH
|
|
+ tristate "Atheros AR91xx parallel flash support"
|
|
+ depends on ATHEROS_AR71XX
|
|
+ select MTD_COMPLEX_MAPPINGS
|
|
+ help
|
|
+ Parallel flash driver for the Atheros AR91xx based boards.
|
|
+
|
|
config MTD_DILNETPC
|
|
tristate "CFI Flash device mapped on DIL/Net PC"
|
|
depends on X86 && MTD_PARTITIONS && MTD_CFI_INTELEXT && BROKEN
|
|
--- a/drivers/mtd/maps/Makefile
|
|
+++ b/drivers/mtd/maps/Makefile
|
|
@@ -40,6 +40,7 @@ obj-$(CONFIG_MTD_SCx200_DOCFLASH)+= scx2
|
|
obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.o
|
|
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
|
|
obj-$(CONFIG_MTD_PCI) += pci.o
|
|
+obj-$(CONFIG_MTD_AR91XX_FLASH) += ar91xx_flash.o
|
|
obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
|
|
obj-$(CONFIG_MTD_EDB7312) += edb7312.o
|
|
obj-$(CONFIG_MTD_IMPA7) += impa7.o
|