mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:37:29 +02:00
dcacfadb50
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10630 3c298f89-4303-0410-b956-a3cf2f4a3e73
190 lines
5.8 KiB
Diff
190 lines
5.8 KiB
Diff
Index: linux-2.6.24/arch/arm/mach-ixp4xx/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.24.orig/arch/arm/mach-ixp4xx/Kconfig 2008-03-12 21:21:26.000000000 +1030
|
|
+++ linux-2.6.24/arch/arm/mach-ixp4xx/Kconfig 2008-03-12 21:21:26.000000000 +1030
|
|
@@ -65,6 +65,14 @@
|
|
Engineering Pronghorn Metro Platform. For more
|
|
information on this platform, see <file:Documentation/arm/IXP4xx>.
|
|
|
|
+config MACH_COMPEX
|
|
+ bool "Compex WP18 / NP18A"
|
|
+ select PCI
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support Compex'
|
|
+ WP18 or NP18A boards. For more information on this
|
|
+ platform, see http://openwrt.org
|
|
+
|
|
config ARCH_IXDP425
|
|
bool "IXDP425"
|
|
help
|
|
Index: linux-2.6.24/arch/arm/mach-ixp4xx/Makefile
|
|
===================================================================
|
|
--- linux-2.6.24.orig/arch/arm/mach-ixp4xx/Makefile 2008-03-12 21:21:26.000000000 +1030
|
|
+++ linux-2.6.24/arch/arm/mach-ixp4xx/Makefile 2008-03-12 21:21:26.000000000 +1030
|
|
@@ -17,6 +17,7 @@
|
|
obj-pci-$(CONFIG_MACH_WG302V2) += wg302v2-pci.o
|
|
obj-pci-$(CONFIG_MACH_FSG) += fsg-pci.o
|
|
obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
|
|
+obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
|
|
|
|
obj-y += common.o
|
|
|
|
@@ -32,5 +33,6 @@
|
|
obj-$(CONFIG_MACH_WG302V2) += wg302v2-setup.o
|
|
obj-$(CONFIG_MACH_FSG) += fsg-setup.o
|
|
obj-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-setup.o
|
|
+obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
|
|
|
|
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
|
|
Index: linux-2.6.24/arch/arm/mach-ixp4xx/compex-setup.c
|
|
===================================================================
|
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
+++ linux-2.6.24/arch/arm/mach-ixp4xx/compex-setup.c 2008-03-12 21:21:26.000000000 +1030
|
|
@@ -0,0 +1,120 @@
|
|
+/*
|
|
+ * arch/arm/mach-ixp4xx/compex-setup.c
|
|
+ *
|
|
+ * Ccompex WP18 / NP18A board-setup
|
|
+ *
|
|
+ * Copyright (C) 2007 Imre Kaloz <Kaloz@openwrt.org>
|
|
+ *
|
|
+ * based on ixdp425-setup.c:
|
|
+ * Copyright (C) 2003-2005 MontaVista Software, Inc.
|
|
+ *
|
|
+ * Author: Imre Kaloz <Kaloz@openwrt.org>
|
|
+ */
|
|
+
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/init.h>
|
|
+#include <linux/device.h>
|
|
+#include <linux/serial.h>
|
|
+#include <linux/tty.h>
|
|
+#include <linux/serial_8250.h>
|
|
+#include <linux/slab.h>
|
|
+
|
|
+#include <asm/types.h>
|
|
+#include <asm/setup.h>
|
|
+#include <asm/memory.h>
|
|
+#include <asm/hardware.h>
|
|
+#include <asm/mach-types.h>
|
|
+#include <asm/irq.h>
|
|
+#include <asm/mach/arch.h>
|
|
+#include <asm/mach/flash.h>
|
|
+
|
|
+static struct flash_platform_data compex_flash_data = {
|
|
+ .map_name = "cfi_probe",
|
|
+ .width = 2,
|
|
+};
|
|
+
|
|
+static struct resource compex_flash_resource = {
|
|
+ .flags = IORESOURCE_MEM,
|
|
+};
|
|
+
|
|
+static struct platform_device compex_flash = {
|
|
+ .name = "IXP4XX-Flash",
|
|
+ .id = 0,
|
|
+ .dev = {
|
|
+ .platform_data = &compex_flash_data,
|
|
+ },
|
|
+ .num_resources = 1,
|
|
+ .resource = &compex_flash_resource,
|
|
+};
|
|
+
|
|
+static struct resource compex_uart_resources[] = {
|
|
+ {
|
|
+ .start = IXP4XX_UART1_BASE_PHYS,
|
|
+ .end = IXP4XX_UART1_BASE_PHYS + 0x0fff,
|
|
+ .flags = IORESOURCE_MEM
|
|
+ },
|
|
+ {
|
|
+ .start = IXP4XX_UART2_BASE_PHYS,
|
|
+ .end = IXP4XX_UART2_BASE_PHYS + 0x0fff,
|
|
+ .flags = IORESOURCE_MEM
|
|
+ }
|
|
+};
|
|
+
|
|
+static struct plat_serial8250_port compex_uart_data[] = {
|
|
+ {
|
|
+ .mapbase = IXP4XX_UART1_BASE_PHYS,
|
|
+ .membase = (char *)IXP4XX_UART1_BASE_VIRT + REG_OFFSET,
|
|
+ .irq = IRQ_IXP4XX_UART1,
|
|
+ .flags = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
|
|
+ .iotype = UPIO_MEM,
|
|
+ .regshift = 2,
|
|
+ .uartclk = IXP4XX_UART_XTAL,
|
|
+ },
|
|
+ {
|
|
+ .mapbase = IXP4XX_UART2_BASE_PHYS,
|
|
+ .membase = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
|
|
+ .irq = IRQ_IXP4XX_UART2,
|
|
+ .flags = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
|
|
+ .iotype = UPIO_MEM,
|
|
+ .regshift = 2,
|
|
+ .uartclk = IXP4XX_UART_XTAL,
|
|
+ },
|
|
+ { },
|
|
+};
|
|
+
|
|
+static struct platform_device compex_uart = {
|
|
+ .name = "serial8250",
|
|
+ .id = PLAT8250_DEV_PLATFORM,
|
|
+ .dev.platform_data = compex_uart_data,
|
|
+ .num_resources = 2,
|
|
+ .resource = compex_uart_resources,
|
|
+};
|
|
+
|
|
+static struct platform_device *compex_devices[] __initdata = {
|
|
+ &compex_flash,
|
|
+ &compex_uart
|
|
+};
|
|
+
|
|
+static void __init compex_init(void)
|
|
+{
|
|
+ ixp4xx_sys_init();
|
|
+
|
|
+ compex_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
|
|
+ compex_flash_resource.end =
|
|
+ IXP4XX_EXP_BUS_BASE(0) + SZ_32M - 1;
|
|
+
|
|
+ platform_add_devices(compex_devices, ARRAY_SIZE(compex_devices));
|
|
+}
|
|
+
|
|
+#ifdef CONFIG_MACH_COMPEX
|
|
+MACHINE_START(COMPEX, "Compex WP18 / NP18A")
|
|
+ /* Maintainer: Imre Kaloz <Kaloz@openwrt.org> */
|
|
+ .phys_io = IXP4XX_PERIPHERAL_BASE_PHYS,
|
|
+ .io_pg_offst = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
|
|
+ .map_io = ixp4xx_map_io,
|
|
+ .init_irq = ixp4xx_init_irq,
|
|
+ .timer = &ixp4xx_timer,
|
|
+ .boot_params = 0x0100,
|
|
+ .init_machine = compex_init,
|
|
+MACHINE_END
|
|
+#endif
|
|
Index: linux-2.6.24/arch/arm/mach-ixp4xx/ixdp425-pci.c
|
|
===================================================================
|
|
--- linux-2.6.24.orig/arch/arm/mach-ixp4xx/ixdp425-pci.c 2008-03-12 21:20:48.000000000 +1030
|
|
+++ linux-2.6.24/arch/arm/mach-ixp4xx/ixdp425-pci.c 2008-03-12 21:21:26.000000000 +1030
|
|
@@ -66,7 +66,7 @@
|
|
int __init ixdp425_pci_init(void)
|
|
{
|
|
if (machine_is_ixdp425() || machine_is_ixcdp1100() ||
|
|
- machine_is_ixdp465() || machine_is_kixrp435())
|
|
+ machine_is_ixdp465() || machine_is_kixrp435() || machine_is_compex())
|
|
pci_common_init(&ixdp425_pci);
|
|
return 0;
|
|
}
|
|
Index: linux-2.6.24/arch/arm/tools/mach-types
|
|
===================================================================
|
|
--- linux-2.6.24.orig/arch/arm/tools/mach-types 2008-03-12 21:20:48.000000000 +1030
|
|
+++ linux-2.6.24/arch/arm/tools/mach-types 2008-03-12 21:21:26.000000000 +1030
|
|
@@ -1278,7 +1278,7 @@
|
|
smdk6400 MACH_SMDK6400 SMDK6400 1270
|
|
nokia_n800 MACH_NOKIA_N800 NOKIA_N800 1271
|
|
greenphone MACH_GREENPHONE GREENPHONE 1272
|
|
-compex42x MACH_COMPEXWP18 COMPEXWP18 1273
|
|
+compex MACH_COMPEX COMPEX 1273
|
|
xmate MACH_XMATE XMATE 1274
|
|
energizer MACH_ENERGIZER ENERGIZER 1275
|
|
ime1 MACH_IME1 IME1 1276
|