1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 20:31:07 +03:00
openwrt-xburst/package/mac80211/patches/110-disable_usb_compat.patch
nbd a3657acc2b mac80211: update to wireless-testing 2012-05-29
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32002 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-05-30 01:01:06 +00:00

45 lines
1.4 KiB
Diff

--- a/compat/compat-2.6.28.c
+++ b/compat/compat-2.6.28.c
@@ -165,7 +165,7 @@ EXPORT_SYMBOL_GPL(pcmcia_loop_config);
#endif /* CONFIG_PCMCIA */
-#if defined(CONFIG_USB) || defined(CONFIG_USB_MODULE)
+#if 0
void usb_unpoison_urb(struct urb *urb)
{
--- a/compat/compat-2.6.29.c
+++ b/compat/compat-2.6.29.c
@@ -49,7 +49,7 @@ void netdev_attach_ops(struct net_device
EXPORT_SYMBOL_GPL(netdev_attach_ops);
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
-#if defined(CONFIG_USB) || defined(CONFIG_USB_MODULE)
+#if 0
/**
* usb_unpoison_anchored_urbs - let an anchor be used successfully again
* @anchor: anchor the requests are bound to
--- a/include/linux/compat-2.6.28.h
+++ b/include/linux/compat-2.6.28.h
@@ -73,7 +73,7 @@ int pcmcia_loop_config(struct pcmcia_dev
/* USB anchors were added as of 2.6.23 */
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
-#if defined(CONFIG_USB) || defined(CONFIG_USB_MODULE)
+#if 0
#if 0
extern void usb_poison_urb(struct urb *urb);
#endif
--- a/config.mk
+++ b/config.mk
@@ -506,7 +506,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
# This activates a threading fix for usb urb.
# this is mainline commit: b3e670443b7fb8a2d29831b62b44a039c283e351
# This fix will be included in some stable releases.
-export CONFIG_COMPAT_USB_URB_THREAD_FIX=y
+# export CONFIG_COMPAT_USB_URB_THREAD_FIX=y
export CONFIG_ATH9K_HTC=m
# export CONFIG_ATH9K_HTC_DEBUGFS=y