1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-05 00:42:02 +03:00
openwrt-xburst/target/linux/s3c24xx/patches-2.6.30/014-neo1973_mach.patch
lars d6694fb05e [s3c24xx] Get rid of gpio shadowing.
I fail really to see why this would be necessary here. So get rid of it and see if
anything breaks...


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17052 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-07-30 15:08:05 +00:00

44 lines
1.2 KiB
Diff

--- a/arch/arm/plat-s3c24xx/Kconfig
+++ b/arch/arm/plat-s3c24xx/Kconfig
@@ -112,4 +112,20 @@ config MACH_SMDK
help
Common machine code for SMDK2410 and SMDK2440
+config MACH_NEO1973
+ bool
+ select RFKILL
+ select SERIAL_SAMSUNG
+ select SERIAL_SAMSUNG_CONSOLE
+ help
+ Common machine code for Neo1973 hardware
+
+config MACH_NEO1973
+ bool
+ select RFKILL
+ select SERIAL_SAMSUNG
+ select SERIAL_SAMSUNG_CONSOLE
+ help
+ Common machine code for Neo1973 hardware
+
endif
--- a/arch/arm/mach-s3c2442/Makefile
+++ b/arch/arm/mach-s3c2442/Makefile
@@ -14,3 +14,8 @@ obj-$(CONFIG_CPU_S3C2442) += clock.o
# Machine support
+obj-$(CONFIG_MACH_NEO1973) += \
+ gta02-pm-gsm.o \
+ gta02-pm-gps.o \
+ gta02-pm-bt.o \
+ gta02-pm-wlan.o
--- a/drivers/misc/Makefile
+++ b/drivers/misc/Makefile
@@ -21,3 +21,6 @@ obj-$(CONFIG_HP_ILO) += hpilo.o
obj-$(CONFIG_ISL29003) += isl29003.o
obj-$(CONFIG_C2PORT) += c2port/
obj-y += eeprom/
+obj-$(CONFIG_MACH_NEO1973) += gta02_pm_host.o \
+ gta02_pm_resume_reason.o
+