1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 04:29:26 +03:00
openwrt-xburst/target/linux/ifxmips/patches/110-drivers.patch
blogic bc8c3990b6 bump ifxmips to 2.6.26.2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12557 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-09-09 00:09:51 +00:00

176 lines
6.9 KiB
Diff

Index: linux-2.6.26.2/drivers/char/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/char/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/char/Makefile 2008-09-09 01:45:41.000000000 +0200
@@ -114,6 +114,10 @@
obj-$(CONFIG_JS_RTC) += js-rtc.o
js-rtc-y = rtc.o
+obj-$(CONFIG_IFXMIPS_SSC) += ifxmips_ssc.o
+obj-$(CONFIG_IFXMIPS_EEPROM) += ifxmips_eeprom.o
+obj-$(CONFIG_IFXMIPS_MEI) += ifxmips_mei_core.o
+
# Files generated that shall be removed upon make clean
clean-files := consolemap_deftbl.c defkeymap.c
Index: linux-2.6.26.2/drivers/mtd/maps/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/mtd/maps/Makefile 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/mtd/maps/Makefile 2008-09-09 01:45:41.000000000 +0200
@@ -67,3 +67,4 @@
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
Index: linux-2.6.26.2/drivers/net/Kconfig
===================================================================
--- linux-2.6.26.2.orig/drivers/net/Kconfig 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/net/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -351,6 +351,12 @@
source "drivers/net/arm/Kconfig"
+config IFXMIPS_MII0
+ tristate "Infineon IFXMips eth0 driver"
+ depends on IFXMIPS
+ help
+ Support for the MII0 inside the IFXMips SOC
+
config AX88796
tristate "ASIX AX88796 NE2000 clone support"
depends on ARM || MIPS || SUPERH
Index: linux-2.6.26.2/drivers/serial/Kconfig
===================================================================
--- linux-2.6.26.2.orig/drivers/serial/Kconfig 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/serial/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -1334,6 +1334,14 @@
Currently, only 8250 compatible ports are supported, but
others can easily be added.
+config SERIAL_IFXMIPS
+ bool "IFXMips serial driver"
+ depends on IFXMIPS
+ select SERIAL_CORE
+ select SERIAL_CORE_CONSOLE
+ help
+ Driver for the ifxmipss built in ASC hardware
+
config SERIAL_QE
tristate "Freescale QUICC Engine serial port support"
depends on QUICC_ENGINE
Index: linux-2.6.26.2/drivers/serial/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/serial/Makefile 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/serial/Makefile 2008-09-09 01:46:23.000000000 +0200
@@ -68,3 +68,4 @@
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
Index: linux-2.6.26.2/drivers/watchdog/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/watchdog/Makefile 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/watchdog/Makefile 2008-09-09 01:45:41.000000000 +0200
@@ -97,6 +97,7 @@
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
# PARISC Architecture
Index: linux-2.6.26.2/drivers/net/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/net/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/net/Makefile 2008-09-09 01:47:02.000000000 +0200
@@ -256,4 +256,4 @@
obj-$(CONFIG_NIU) += niu.o
obj-$(CONFIG_VIRTIO_NET) += virtio_net.o
obj-$(CONFIG_SFC) += sfc/
-
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
Index: linux-2.6.26.2/drivers/crypto/Kconfig
===================================================================
--- linux-2.6.26.2.orig/drivers/crypto/Kconfig 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/crypto/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -9,6 +9,9 @@
If you say N, all options in this submenu will be skipped and disabled.
if CRYPTO_HW
+config CRYPTO_DEV_IFXMIPS
+ tristate "Support for IFXMIPS Data Encryption Unit"
+ depends on IFXMIPS
config CRYPTO_DEV_PADLOCK
tristate "Support for VIA PadLock ACE"
Index: linux-2.6.26.2/drivers/crypto/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/crypto/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/crypto/Makefile 2008-09-09 01:47:30.000000000 +0200
@@ -4,3 +4,4 @@
obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hifn_795x.o
obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o
obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
+obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o
Index: linux-2.6.26.2/drivers/usb/host/Kconfig
===================================================================
--- linux-2.6.26.2.orig/drivers/usb/host/Kconfig 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/usb/host/Kconfig 2008-09-09 01:48:14.000000000 +0200
@@ -305,3 +305,10 @@
help
This driver enables support for the on-chip R8A66597 in the
SH7366 and SH7723 processors.
+
+config USB_DWC_HCD
+ tristate "IFXMIPS USB Host Controller Driver"
+ depends on USB && IFXMIPS
+ default y
+ help
+ Danube USB Host Controller
Index: linux-2.6.26.2/drivers/leds/Kconfig
===================================================================
--- linux-2.6.26.2.orig/drivers/leds/Kconfig 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/leds/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -153,6 +153,12 @@
To compile this driver as a module, choose M here: the
module will be called leds-clevo-mail.
+config LEDS_IFXMIPS
+ tristate "LED Support for IFXMIPS LEDs"
+ depends on LEDS_CLASS && IFXMIPS
+ help
+ This option enables support for the CM-X270 LEDs.
+
comment "LED Triggers"
config LEDS_TRIGGERS
Index: linux-2.6.26.2/drivers/leds/Makefile
===================================================================
--- linux-2.6.26.2.orig/drivers/leds/Makefile 2008-09-09 01:44:53.000000000 +0200
+++ linux-2.6.26.2/drivers/leds/Makefile 2008-09-09 01:49:25.000000000 +0200
@@ -22,6 +22,7 @@
obj-$(CONFIG_LEDS_CLEVO_MAIL) += leds-clevo-mail.o
obj-$(CONFIG_LEDS_HP6XX) += leds-hp6xx.o
obj-$(CONFIG_LEDS_FSG) += leds-fsg.o
+obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
# LED Triggers
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
Index: linux-2.6.26.2/drivers/watchdog/Kconfig
===================================================================
--- linux-2.6.26.2.orig/drivers/watchdog/Kconfig 2008-09-09 01:44:51.000000000 +0200
+++ linux-2.6.26.2/drivers/watchdog/Kconfig 2008-09-09 01:45:41.000000000 +0200
@@ -683,6 +683,12 @@
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+config IFXMIPS_WDT
+ bool "IFXMips watchdog"
+ depends on IFXMIPS
+ help
+ Hardware driver for the IFXMIPS Watchdog Timer.
+
# PARISC Architecture
# POWERPC Architecture