mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:04:05 +02:00
df67b62940
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19811 3c298f89-4303-0410-b956-a3cf2f4a3e73
49 lines
1.3 KiB
Diff
49 lines
1.3 KiB
Diff
--- a/pppd/Makefile.linux
|
|
+++ b/pppd/Makefile.linux
|
|
@@ -48,7 +48,7 @@ MPPE=y
|
|
# Uncomment the next line to include support for PPP packet filtering.
|
|
# This requires that the libpcap library and headers be installed
|
|
# and that the kernel driver support PPP packet filtering.
|
|
-FILTER=y
|
|
+#FILTER=y
|
|
|
|
# Uncomment the next line to enable multilink PPP (enabled by default)
|
|
# Linux distributions: Please leave multilink ENABLED in your builds
|
|
@@ -58,11 +58,11 @@ HAVE_MULTILINK=y
|
|
# Uncomment the next line to enable the TDB database (enabled by default.)
|
|
# If you enable multilink, then TDB is automatically enabled also.
|
|
# Linux distributions: Please leave TDB ENABLED in your builds.
|
|
-USE_TDB=y
|
|
+#USE_TDB=y
|
|
|
|
-HAS_SHADOW=y
|
|
+#HAS_SHADOW=y
|
|
#USE_PAM=y
|
|
-#HAVE_INET6=y
|
|
+HAVE_INET6=y
|
|
|
|
# Enable plugins
|
|
PLUGIN=y
|
|
@@ -77,7 +77,7 @@ MAXOCTETS=y
|
|
|
|
INCLUDE_DIRS= -I../include
|
|
|
|
-COMPILE_FLAGS= -DHAVE_PATHS_H -DIPX_CHANGE -DHAVE_MMAP
|
|
+COMPILE_FLAGS= -DHAVE_PATHS_H -DHAVE_MMAP
|
|
|
|
CFLAGS= $(COPTS) $(COMPILE_FLAGS) $(INCLUDE_DIRS) '-DDESTDIR="@DESTDIR@"'
|
|
|
|
@@ -117,10 +117,10 @@ CFLAGS += -DHAS_SHADOW
|
|
#LIBS += -lshadow $(LIBS)
|
|
endif
|
|
|
|
-ifneq ($(wildcard /usr/include/crypt.h),)
|
|
+#ifneq ($(wildcard /usr/include/crypt.h),)
|
|
CFLAGS += -DHAVE_CRYPT_H=1
|
|
LIBS += -lcrypt
|
|
-endif
|
|
+#endif
|
|
|
|
ifdef NEEDDES
|
|
ifndef USE_CRYPT
|