1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 19:43:16 +03:00
openwrt-xburst/package/ppp/patches/300-filter-pcap-includes-lib.patch
jow 5cae7371a7 [package] ppp: annotate most patches with description and S-o-b
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32463 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-06-19 17:03:24 +00:00

21 lines
485 B
Diff

build: Add required CFLAGS for libpcap
This patch adds some flags to required to properly link libpcap within the
OpenWrt environment.
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
--- a/pppd/Makefile.linux
+++ b/pppd/Makefile.linux
@@ -170,8 +170,8 @@ endif
ifdef FILTER
ifneq ($(wildcard /usr/include/pcap-bpf.h),)
-LIBS += -lpcap
-CFLAGS += -DPPP_FILTER
+LIBS += -lpcap -L$(STAGING_DIR)/usr/lib
+CFLAGS += -DPPP_FILTER -I$(STAGING_DIR)/usr/include
endif
endif