1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 13:52:26 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.28/970-ocf_kbuild_integration.patch
juhosg 554d839714 [kernel] refresh 2.6.28 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13654 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-12-15 14:48:40 +00:00

26 lines
534 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -735,6 +735,8 @@ config CRYPTO_ANSI_CPRNG
for cryptographic modules. Uses the Algorithm specified in
ANSI X9.31 A.2.4
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -79,6 +79,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o