1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 14:15:51 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch
florian a8a51aaf29 [kernel] refresh 2.6.31 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18334 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-11-07 12:45:41 +00:00

36 lines
704 B
Diff

--- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile
@@ -2,6 +2,8 @@
# Makefile for the Linux/MIPS kernel.
#
+CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS) $(EXTRA_LDSFLAGS)
+
extra-y := head.o init_task.o vmlinux.lds
obj-y += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
--- a/arch/mips/kernel/vmlinux.lds.S
+++ b/arch/mips/kernel/vmlinux.lds.S
@@ -10,15 +10,15 @@ PHDRS {
note PT_NOTE FLAGS(4); /* R__ */
}
-ifdef CONFIG_32BIT
- ifdef CONFIG_CPU_LITTLE_ENDIAN
+#ifdef CONFIG_32BIT
+ #ifdef CONFIG_CPU_LITTLE_ENDIAN
jiffies = jiffies_64;
- else
+ #else
jiffies = jiffies_64 + 4;
- endif
-else
+ #endif
+#else
jiffies = jiffies_64;
-endif
+#endif
SECTIONS
{