1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 14:15:51 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
kaloz 4c1bc63b76 resync 2.6.30/2.6.31 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18270 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-11-02 09:54:06 +00:00

26 lines
534 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -788,6 +788,8 @@ config CRYPTO_ANSI_CPRNG
for cryptographic modules. Uses the Algorithm specified in
ANSI X9.31 A.2.4
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o