1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2025-01-27 22:11:06 +02:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
juhosg afc90574b4 [kernel] refresh generic 2.6.25 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11189 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-18 20:26:43 +00:00

15 lines
495 B
Diff

Index: linux-2.6.25.4/Makefile
===================================================================
--- linux-2.6.25.4.orig/Makefile
+++ linux-2.6.25.4/Makefile
@@ -533,6 +533,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)