1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 18:04:17 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch
blogic d29ad00711 makes ledtrignetdev work on .26 and fix whitespaces
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12090 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-08-04 14:05:04 +00:00

26 lines
1.0 KiB
Diff

Index: linux-2.6.26/drivers/leds/Kconfig
===================================================================
--- linux-2.6.26.orig/drivers/leds/Kconfig 2008-08-04 15:03:44.000000000 +0200
+++ linux-2.6.26/drivers/leds/Kconfig 2008-08-04 15:04:18.000000000 +0200
@@ -200,4 +200,11 @@
tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS
+config LEDS_TRIGGER_NETDEV
+ tristate "LED Netdev Trigger"
+ depends on LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
endif # NEW_LEDS
Index: linux-2.6.26/drivers/leds/Makefile
===================================================================
--- linux-2.6.26.orig/drivers/leds/Makefile 2008-08-04 15:03:40.000000000 +0200
+++ linux-2.6.26/drivers/leds/Makefile 2008-08-04 15:04:29.000000000 +0200
@@ -29,3 +29,4 @@
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o