mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:11:51 +02:00
4c6cfc925c
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26803 3c298f89-4303-0410-b956-a3cf2f4a3e73
22 lines
754 B
Diff
22 lines
754 B
Diff
--- a/arch/um/Makefile-i386
|
|
+++ b/arch/um/Makefile-i386
|
|
@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
|
|
echo $(call cc-option,-fno-unit-at-a-time); \
|
|
else echo $(call cc-option,-funit-at-a-time); fi ;)
|
|
|
|
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
|
|
+# and later
|
|
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
|
|
+
|
|
KBUILD_CFLAGS += $(cflags-y)
|
|
--- a/arch/um/Makefile-x86_64
|
|
+++ b/arch/um/Makefile-x86_64
|
|
@@ -24,3 +24,7 @@ LINK-y += -m64
|
|
|
|
# Do unit-at-a-time unconditionally on x86_64, following the host
|
|
KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
|
|
+
|
|
+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
|
|
+# and later
|
|
+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
|