mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
55664ae04b
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25641 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
842 B
Diff
27 lines
842 B
Diff
--- a/drivers/watchdog/Kconfig
|
|
+++ b/drivers/watchdog/Kconfig
|
|
@@ -930,6 +930,13 @@ config BCM63XX_WDT
|
|
To compile this driver as a loadable module, choose M here.
|
|
The module will be called bcm63xx_wdt.
|
|
|
|
+config AR71XX_WDT
|
|
+ tristate "Atheros AR71xx Watchdog Timer"
|
|
+ depends on ATHEROS_AR71XX
|
|
+ help
|
|
+ Hardware driver for the built-in watchdog timer on the Atheros
|
|
+ AR71xx SoCs.
|
|
+
|
|
# PARISC Architecture
|
|
|
|
# POWERPC Architecture
|
|
--- a/drivers/watchdog/Makefile
|
|
+++ b/drivers/watchdog/Makefile
|
|
@@ -115,6 +115,7 @@ obj-$(CONFIG_INDYDOG) += indydog.o
|
|
obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
|
|
obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt.o
|
|
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
|
+obj-$(CONFIG_AR71XX_WDT) += ar71xx_wdt.o
|
|
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
|
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
|
obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
|