1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-28 20:23:52 +03:00
openwrt-xburst/package/network/config/ltq-dsl-app/patches/010-eglibc_compile_fix.patch
mirko 3abfc82ebe Make ltq-dsl-app compile with an eglibc-based toolchain
Signed-Off-By: Frank Meerkötter <frank@meerkoetter.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34468 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-12-03 12:46:57 +00:00

24 lines
647 B
Diff

--- a/configure.in
+++ b/configure.in
@@ -29,6 +29,8 @@ AC_C_VOLATILE
#AC_FUNC_STRTOD
#AC_CHECK_FUNCS([ftime gethostbyname gettimeofday localtime_r memset select socket strchr strerror strstr strtoull])
+AC_SEARCH_LIBS([clock_gettime],[rt])
+
#
# save the configure arguments
#
--- a/src/dsl_cpe_linux.h
+++ b/src/dsl_cpe_linux.h
@@ -45,7 +45,8 @@
#include <arpa/inet.h>
#include <sys/socket.h> /* socket */
#include <sys/sem.h> /* semget */
-#include <semaphore.h> /* sem_t */
+#include <semaphore.h> /* sem_t */
+#include <limits.h>
#ifdef DSL_DEBUG_TOOL_INTERFACE
#include <sys/socket.h>