1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-22 12:29:48 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.22/004-extra_optimization.patch
juhosg ff4e17bc25 [kernel] refresh generic 2.6.22 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11186 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-18 20:24:13 +00:00

15 lines
526 B
Diff

Index: linux-2.6.22.19/Makefile
===================================================================
--- linux-2.6.22.19.orig/Makefile
+++ linux-2.6.22.19/Makefile
@@ -507,6 +507,9 @@ CFLAGS += $(call cc-option, -fn
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)