mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 16:22:49 +02:00
dc2f3c0139
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10566 3c298f89-4303-0410-b956-a3cf2f4a3e73
26 lines
1.1 KiB
Diff
26 lines
1.1 KiB
Diff
Index: linux-2.6.23.16/drivers/leds/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.23.16.orig/drivers/leds/Kconfig 2008-03-07 21:26:46.000000000 +0100
|
|
+++ linux-2.6.23.16/drivers/leds/Kconfig 2008-03-07 21:27:50.000000000 +0100
|
|
@@ -150,4 +150,11 @@
|
|
This allows LEDs to be initialised in the ON state.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_NETDEV
|
|
+ tristate "LED Netdev Trigger"
|
|
+ depends on LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by network device activity.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # NEW_LEDS
|
|
Index: linux-2.6.23.16/drivers/leds/Makefile
|
|
===================================================================
|
|
--- linux-2.6.23.16.orig/drivers/leds/Makefile 2008-03-07 21:28:01.000000000 +0100
|
|
+++ linux-2.6.23.16/drivers/leds/Makefile 2008-03-07 21:36:07.000000000 +0100
|
|
@@ -25,3 +25,4 @@
|
|
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|