1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 04:09:23 +03:00
openwrt-xburst/target/linux/generic-2.4/patches/010-disable_old_squashfs_compatibility.patch
agb 0ec45ff596 [kernel] generic-2.4: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15860 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-05-15 10:36:04 +00:00

24 lines
562 B
Diff

--- a/fs/squashfs/Makefile
+++ b/fs/squashfs/Makefile
@@ -4,7 +4,7 @@
O_TARGET := squashfs.o
-obj-y := inode.o squashfs2_0.o LzmaDecode.o
+obj-y := inode.o LzmaDecode.o
obj-m := $(O_TARGET)
--- a/fs/squashfs/squashfs.h
+++ b/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)
#else