1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 05:31:10 +03:00
openwrt-xburst/target/linux/ifxmips/patches-2.6.33/100-board.patch
blogic 656f01b9c9 [ifxmips] adss 2.6.33 kernel patches, not defult yet as linux-atm breaks on 2.6.33
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20789 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-04-10 20:11:28 +00:00

59 lines
2.0 KiB
Diff

Index: linux-2.6.33.2/arch/mips/Kconfig
===================================================================
--- linux-2.6.33.2.orig/arch/mips/Kconfig 2010-04-02 23:31:00.000000000 +0200
+++ linux-2.6.33.2/arch/mips/Kconfig 2010-04-02 23:38:38.000000000 +0200
@@ -139,6 +139,9 @@
otherwise choose R3000.
+config IFXMIPS
+ bool "Infineon MIPS"
+
config MACH_JAZZ
bool "Jazz family of machines"
select ARC
@@ -693,6 +696,7 @@
source "arch/mips/vr41xx/Kconfig"
source "arch/mips/cavium-octeon/Kconfig"
source "arch/mips/loongson/Kconfig"
+source "arch/mips/ifxmips/Kconfig"
endmenu
Index: linux-2.6.33.2/arch/mips/Makefile
===================================================================
--- linux-2.6.33.2.orig/arch/mips/Makefile 2010-04-02 23:31:01.000000000 +0200
+++ linux-2.6.33.2/arch/mips/Makefile 2010-04-02 23:38:38.000000000 +0200
@@ -317,6 +317,18 @@
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
#
+# Infineon IFXMIPS
+#
+core-$(CONFIG_IFXMIPS) += arch/mips/ifxmips/common/
+cflags-$(CONFIG_IFXMIPS) += -I$(srctree)/arch/mips/include/asm/mach-ifxmips
+
+core-$(CONFIG_IFXMIPS_DANUBE) += arch/mips/ifxmips/danube/
+cflags-$(CONFIG_IFXMIPS_DANUBE) += -I$(srctree)/arch/mips/include/asm/mach-ifxmips/danube/
+load-$(CONFIG_IFXMIPS_DANUBE) += 0xffffffff80002000
+
+core-$(CONFIG_IFXMIPS_COMPAT) += arch/mips/ifxmips/compat/
+
+#
# DECstation family
#
core-$(CONFIG_MACH_DECSTATION) += arch/mips/dec/
Index: linux-2.6.33.2/arch/mips/pci/Makefile
===================================================================
--- linux-2.6.33.2.orig/arch/mips/pci/Makefile 2010-04-02 01:02:33.000000000 +0200
+++ linux-2.6.33.2/arch/mips/pci/Makefile 2010-04-02 23:38:38.000000000 +0200
@@ -55,7 +55,7 @@
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += pci-octeon.o pcie-octeon.o
-
+obj-$(CONFIG_IFXMIPS) += pci-ifxmips.o ops-ifxmips.o
ifdef CONFIG_PCI_MSI
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
endif