1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-15 16:05:20 +03:00
openwrt-xburst/package/madwifi/patches/106-get_arch.patch
nbd c537863342 madwifi: fix noderef and state machine issues in the currently unused ap-to-ap wds mode; refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13096 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-11-02 13:04:36 +00:00

17 lines
320 B
Diff

--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
$(Cannot determine ARCH)
endif
+# Allow ARCH to be x86
+ifneq (,$(CONFIG_X86))
+ifeq (x86,$(ARCH))
+ARCH-y = $(ARCH)
+endif
+endif
+
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)