1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-17 22:48:02 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.25/009-adm5120_leds_switch_trigger.patch
juhosg 33d5882433 [adm5120] refresh patches to match upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11374 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-06-06 08:54:13 +00:00

23 lines
758 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -213,4 +213,12 @@
This allows LEDs to be initialised in the ON state.
If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && LEDS_ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -30,3 +30,4 @@
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o