mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-06 15:19:40 +02:00
47ef8de260
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8348 3c298f89-4303-0410-b956-a3cf2f4a3e73
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
diff -urN linux-2.6.19/arch/i386/Kconfig linux-2.6.19.new/arch/i386/Kconfig
|
|
--- linux-2.6.19/arch/i386/Kconfig 2006-11-29 22:57:37.000000000 +0100
|
|
+++ linux-2.6.19.new/arch/i386/Kconfig 2006-12-17 17:13:33.000000000 +0100
|
|
@@ -180,6 +180,14 @@
|
|
Only choose this option if you have such a system, otherwise you
|
|
should say N here.
|
|
|
|
+config X86_RDC
|
|
+ bool "Support for RDC 3211 boards"
|
|
+ help
|
|
+ Support for RDC 3211 systems. Say 'Y' here if the kernel is
|
|
+ supposed to run on an IA-32 RDC R3211 system.
|
|
+ Only choose this option if you have such as system, otherwise you
|
|
+ should say N here.
|
|
+
|
|
endchoice
|
|
|
|
config ACPI_SRAT
|
|
diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
|
|
--- linux-2.6.19/arch/i386/Makefile 2006-11-29 22:57:37.000000000 +0100
|
|
+++ linux-2.6.19.new/arch/i386/Makefile 2006-12-17 17:13:33.000000000 +0100
|
|
@@ -92,6 +92,10 @@
|
|
mflags-$(CONFIG_X86_ES7000) := -Iinclude/asm-i386/mach-es7000
|
|
mcore-$(CONFIG_X86_ES7000) := mach-default
|
|
core-$(CONFIG_X86_ES7000) := arch/i386/mach-es7000/
|
|
+# RDC subarch support
|
|
+mflags-$(CONFIG_X86_RDC) := -Iinclude/asm-i386/mach-rdc
|
|
+mcore-$(CONFIG_X86_RDC) := mach-default
|
|
+core-$(CONFIG_X86_RDC) += arch/i386/mach-rdc/
|
|
|
|
# default subarch .h files
|
|
mflags-y += -Iinclude/asm-i386/mach-default
|
|
diff -urN linux-2.6.19/arch/i386/mach-rdc/Makefile linux-2.6.19.new/arch/i386/mach-rdc/Makefile
|
|
--- linux-2.6.19/arch/i386/mach-rdc/Makefile 1970-01-01 01:00:00.000000000 +0100
|
|
+++ linux-2.6.19.new/arch/i386/mach-rdc/Makefile 2006-12-17 17:13:33.000000000 +0100
|
|
@@ -0,0 +1,5 @@
|
|
+#
|
|
+# Makefile for the linux kernel.
|
|
+#
|
|
+
|
|
+obj-$(CONFIG_X86_RDC) := gpio.o platform.o
|