mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:47:31 +02:00
55894a40aa
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29627 3c298f89-4303-0410-b956-a3cf2f4a3e73
30 lines
775 B
Diff
30 lines
775 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -13,6 +13,16 @@ menuconfig PHYLIB
|
|
|
|
if PHYLIB
|
|
|
|
+config SWCONFIG
|
|
+ tristate "Switch configuration API"
|
|
+ ---help---
|
|
+ Switch configuration API using netlink. This allows
|
|
+ you to configure the VLAN features of certain switches.
|
|
+
|
|
+config SWCONFIG_LEDS
|
|
+ bool "Switch LED trigger support"
|
|
+ depends on (SWCONFIG && LEDS_TRIGGERS)
|
|
+
|
|
comment "MII PHY device drivers"
|
|
|
|
config MARVELL_PHY
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -3,6 +3,7 @@
|
|
libphy-objs := phy.o phy_device.o mdio_bus.o
|
|
|
|
obj-$(CONFIG_PHYLIB) += libphy.o
|
|
+obj-$(CONFIG_SWCONFIG) += swconfig.o
|
|
obj-$(CONFIG_MARVELL_PHY) += marvell.o
|
|
obj-$(CONFIG_DAVICOM_PHY) += davicom.o
|
|
obj-$(CONFIG_CICADA_PHY) += cicada.o
|