mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 22:25:20 +02:00
31a40f97ef
* add new patches for bcm4716 SoC * add support for serial flash on bcma bus git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27723 3c298f89-4303-0410-b956-a3cf2f4a3e73
791 lines
24 KiB
Diff
791 lines
24 KiB
Diff
--- a/drivers/bcma/Kconfig
|
|
+++ b/drivers/bcma/Kconfig
|
|
@@ -13,6 +13,11 @@ config BCMA
|
|
Bus driver for Broadcom specific Advanced Microcontroller Bus
|
|
Architecture.
|
|
|
|
+# Support for Block-I/O. SELECT this from the driver that needs it.
|
|
+config BCMA_BLOCKIO
|
|
+ bool
|
|
+ depends on BCMA
|
|
+
|
|
config BCMA_HOST_PCI_POSSIBLE
|
|
bool
|
|
depends on BCMA && PCI = y
|
|
@@ -22,6 +27,12 @@ config BCMA_HOST_PCI
|
|
bool "Support for BCMA on PCI-host bus"
|
|
depends on BCMA_HOST_PCI_POSSIBLE
|
|
|
|
+config BCMA_DRIVER_PCI_HOSTMODE
|
|
+ bool "Driver for PCI core working in hostmode"
|
|
+ depends on BCMA && MIPS
|
|
+ help
|
|
+ PCI core hostmode operation (external PCI bus).
|
|
+
|
|
config BCMA_DEBUG
|
|
bool "BCMA debugging"
|
|
depends on BCMA
|
|
--- a/drivers/bcma/Makefile
|
|
+++ b/drivers/bcma/Makefile
|
|
@@ -1,6 +1,7 @@
|
|
-bcma-y += main.o scan.o core.o
|
|
+bcma-y += main.o scan.o core.o sprom.o
|
|
bcma-y += driver_chipcommon.o driver_chipcommon_pmu.o
|
|
bcma-y += driver_pci.o
|
|
+bcma-$(CONFIG_BCMA_DRIVER_PCI_HOSTMODE) += driver_pci_host.o
|
|
bcma-$(CONFIG_BCMA_HOST_PCI) += host_pci.o
|
|
obj-$(CONFIG_BCMA) += bcma.o
|
|
|
|
--- a/drivers/bcma/bcma_private.h
|
|
+++ b/drivers/bcma/bcma_private.h
|
|
@@ -13,16 +13,23 @@
|
|
struct bcma_bus;
|
|
|
|
/* main.c */
|
|
-extern int bcma_bus_register(struct bcma_bus *bus);
|
|
-extern void bcma_bus_unregister(struct bcma_bus *bus);
|
|
+int bcma_bus_register(struct bcma_bus *bus);
|
|
+void bcma_bus_unregister(struct bcma_bus *bus);
|
|
|
|
/* scan.c */
|
|
int bcma_bus_scan(struct bcma_bus *bus);
|
|
|
|
+/* sprom.c */
|
|
+int bcma_sprom_get(struct bcma_bus *bus);
|
|
+
|
|
#ifdef CONFIG_BCMA_HOST_PCI
|
|
/* host_pci.c */
|
|
extern int __init bcma_host_pci_init(void);
|
|
extern void __exit bcma_host_pci_exit(void);
|
|
#endif /* CONFIG_BCMA_HOST_PCI */
|
|
|
|
+#ifdef CONFIG_BCMA_DRIVER_PCI_HOSTMODE
|
|
+void bcma_core_pci_hostmode_init(struct bcma_drv_pci *pc);
|
|
+#endif /* CONFIG_BCMA_DRIVER_PCI_HOSTMODE */
|
|
+
|
|
#endif
|
|
--- a/drivers/bcma/core.c
|
|
+++ b/drivers/bcma/core.c
|
|
@@ -19,7 +19,7 @@ bool bcma_core_is_enabled(struct bcma_de
|
|
}
|
|
EXPORT_SYMBOL_GPL(bcma_core_is_enabled);
|
|
|
|
-static void bcma_core_disable(struct bcma_device *core, u32 flags)
|
|
+void bcma_core_disable(struct bcma_device *core, u32 flags)
|
|
{
|
|
if (bcma_aread32(core, BCMA_RESET_CTL) & BCMA_RESET_CTL_RESET)
|
|
return;
|
|
@@ -31,6 +31,7 @@ static void bcma_core_disable(struct bcm
|
|
bcma_awrite32(core, BCMA_RESET_CTL, BCMA_RESET_CTL_RESET);
|
|
udelay(1);
|
|
}
|
|
+EXPORT_SYMBOL_GPL(bcma_core_disable);
|
|
|
|
int bcma_core_enable(struct bcma_device *core, u32 flags)
|
|
{
|
|
@@ -49,3 +50,75 @@ int bcma_core_enable(struct bcma_device
|
|
return 0;
|
|
}
|
|
EXPORT_SYMBOL_GPL(bcma_core_enable);
|
|
+
|
|
+void bcma_core_set_clockmode(struct bcma_device *core,
|
|
+ enum bcma_clkmode clkmode)
|
|
+{
|
|
+ u16 i;
|
|
+
|
|
+ WARN_ON(core->id.id != BCMA_CORE_CHIPCOMMON &&
|
|
+ core->id.id != BCMA_CORE_PCIE &&
|
|
+ core->id.id != BCMA_CORE_80211);
|
|
+
|
|
+ switch (clkmode) {
|
|
+ case BCMA_CLKMODE_FAST:
|
|
+ bcma_set32(core, BCMA_CLKCTLST, BCMA_CLKCTLST_FORCEHT);
|
|
+ udelay(64);
|
|
+ for (i = 0; i < 1500; i++) {
|
|
+ if (bcma_read32(core, BCMA_CLKCTLST) &
|
|
+ BCMA_CLKCTLST_HAVEHT) {
|
|
+ i = 0;
|
|
+ break;
|
|
+ }
|
|
+ udelay(10);
|
|
+ }
|
|
+ if (i)
|
|
+ pr_err("HT force timeout\n");
|
|
+ break;
|
|
+ case BCMA_CLKMODE_DYNAMIC:
|
|
+ pr_warn("Dynamic clockmode not supported yet!\n");
|
|
+ break;
|
|
+ }
|
|
+}
|
|
+EXPORT_SYMBOL_GPL(bcma_core_set_clockmode);
|
|
+
|
|
+void bcma_core_pll_ctl(struct bcma_device *core, u32 req, u32 status, bool on)
|
|
+{
|
|
+ u16 i;
|
|
+
|
|
+ WARN_ON(req & ~BCMA_CLKCTLST_EXTRESREQ);
|
|
+ WARN_ON(status & ~BCMA_CLKCTLST_EXTRESST);
|
|
+
|
|
+ if (on) {
|
|
+ bcma_set32(core, BCMA_CLKCTLST, req);
|
|
+ for (i = 0; i < 10000; i++) {
|
|
+ if ((bcma_read32(core, BCMA_CLKCTLST) & status) ==
|
|
+ status) {
|
|
+ i = 0;
|
|
+ break;
|
|
+ }
|
|
+ udelay(10);
|
|
+ }
|
|
+ if (i)
|
|
+ pr_err("PLL enable timeout\n");
|
|
+ } else {
|
|
+ pr_warn("Disabling PLL not supported yet!\n");
|
|
+ }
|
|
+}
|
|
+EXPORT_SYMBOL_GPL(bcma_core_pll_ctl);
|
|
+
|
|
+u32 bcma_core_dma_translation(struct bcma_device *core)
|
|
+{
|
|
+ switch (core->bus->hosttype) {
|
|
+ case BCMA_HOSTTYPE_PCI:
|
|
+ if (bcma_aread32(core, BCMA_IOST) & BCMA_IOST_DMA64)
|
|
+ return BCMA_DMA_TRANSLATION_DMA64_CMT;
|
|
+ else
|
|
+ return BCMA_DMA_TRANSLATION_DMA32_CMT;
|
|
+ default:
|
|
+ pr_err("DMA translation unknown for host %d\n",
|
|
+ core->bus->hosttype);
|
|
+ }
|
|
+ return BCMA_DMA_TRANSLATION_NONE;
|
|
+}
|
|
+EXPORT_SYMBOL(bcma_core_dma_translation);
|
|
--- a/drivers/bcma/driver_chipcommon_pmu.c
|
|
+++ b/drivers/bcma/driver_chipcommon_pmu.c
|
|
@@ -53,6 +53,7 @@ static void bcma_pmu_resources_init(stru
|
|
max_msk = 0xFFFF;
|
|
break;
|
|
case 43224:
|
|
+ case 43225:
|
|
break;
|
|
default:
|
|
pr_err("PMU resource config unknown for device 0x%04X\n",
|
|
@@ -74,6 +75,7 @@ void bcma_pmu_swreg_init(struct bcma_drv
|
|
case 0x4313:
|
|
case 0x4331:
|
|
case 43224:
|
|
+ case 43225:
|
|
break;
|
|
default:
|
|
pr_err("PMU switch/regulators init unknown for device "
|
|
@@ -96,11 +98,13 @@ void bcma_pmu_workarounds(struct bcma_dr
|
|
if (bus->chipinfo.rev == 0) {
|
|
pr_err("Workarounds for 43224 rev 0 not fully "
|
|
"implemented\n");
|
|
- bcma_chipco_chipctl_maskset(cc, 0, ~0, 0xF0);
|
|
+ bcma_chipco_chipctl_maskset(cc, 0, ~0, 0x00F000F0);
|
|
} else {
|
|
bcma_chipco_chipctl_maskset(cc, 0, ~0, 0xF0);
|
|
}
|
|
break;
|
|
+ case 43225:
|
|
+ break;
|
|
default:
|
|
pr_err("Workarounds unknown for device 0x%04X\n",
|
|
bus->chipinfo.id);
|
|
--- a/drivers/bcma/driver_pci.c
|
|
+++ b/drivers/bcma/driver_pci.c
|
|
@@ -157,7 +157,67 @@ static void bcma_pcicore_serdes_workarou
|
|
* Init.
|
|
**************************************************/
|
|
|
|
-void bcma_core_pci_init(struct bcma_drv_pci *pc)
|
|
+static void bcma_core_pci_clientmode_init(struct bcma_drv_pci *pc)
|
|
{
|
|
bcma_pcicore_serdes_workaround(pc);
|
|
}
|
|
+
|
|
+static bool bcma_core_pci_is_in_hostmode(struct bcma_drv_pci *pc)
|
|
+{
|
|
+ struct bcma_bus *bus = pc->core->bus;
|
|
+ u16 chipid_top;
|
|
+
|
|
+ chipid_top = (bus->chipinfo.id & 0xFF00);
|
|
+ if (chipid_top != 0x4700 &&
|
|
+ chipid_top != 0x5300)
|
|
+ return false;
|
|
+
|
|
+ if (bus->sprom.boardflags_lo & SSB_PCICORE_BFL_NOPCI)
|
|
+ return false;
|
|
+
|
|
+#if 0
|
|
+ /* TODO: on BCMA we use address from EROM instead of magic formula */
|
|
+ u32 tmp;
|
|
+ return !mips_busprobe32(tmp, (bus->mmio +
|
|
+ (pc->core->core_index * BCMA_CORE_SIZE)));
|
|
+#endif
|
|
+
|
|
+ return true;
|
|
+}
|
|
+
|
|
+void bcma_core_pci_init(struct bcma_drv_pci *pc)
|
|
+{
|
|
+ if (bcma_core_pci_is_in_hostmode(pc)) {
|
|
+#ifdef CONFIG_BCMA_DRIVER_PCI_HOSTMODE
|
|
+ bcma_core_pci_hostmode_init(pc);
|
|
+#else
|
|
+ pr_err("Driver compiled without support for hostmode PCI\n");
|
|
+#endif /* CONFIG_BCMA_DRIVER_PCI_HOSTMODE */
|
|
+ } else {
|
|
+ bcma_core_pci_clientmode_init(pc);
|
|
+ }
|
|
+}
|
|
+
|
|
+int bcma_core_pci_irq_ctl(struct bcma_drv_pci *pc, struct bcma_device *core,
|
|
+ bool enable)
|
|
+{
|
|
+ struct pci_dev *pdev = pc->core->bus->host_pci;
|
|
+ u32 coremask, tmp;
|
|
+ int err;
|
|
+
|
|
+ err = pci_read_config_dword(pdev, BCMA_PCI_IRQMASK, &tmp);
|
|
+ if (err)
|
|
+ goto out;
|
|
+
|
|
+ coremask = BIT(core->core_index) << 8;
|
|
+ if (enable)
|
|
+ tmp |= coremask;
|
|
+ else
|
|
+ tmp &= ~coremask;
|
|
+
|
|
+ err = pci_write_config_dword(pdev, BCMA_PCI_IRQMASK, tmp);
|
|
+
|
|
+out:
|
|
+ return err;
|
|
+}
|
|
+EXPORT_SYMBOL_GPL(bcma_core_pci_irq_ctl);
|
|
--- a/drivers/bcma/host_pci.c
|
|
+++ b/drivers/bcma/host_pci.c
|
|
@@ -65,6 +65,54 @@ static void bcma_host_pci_write32(struct
|
|
iowrite32(value, core->bus->mmio + offset);
|
|
}
|
|
|
|
+#ifdef CONFIG_BCMA_BLOCKIO
|
|
+void bcma_host_pci_block_read(struct bcma_device *core, void *buffer,
|
|
+ size_t count, u16 offset, u8 reg_width)
|
|
+{
|
|
+ void __iomem *addr = core->bus->mmio + offset;
|
|
+ if (core->bus->mapped_core != core)
|
|
+ bcma_host_pci_switch_core(core);
|
|
+ switch (reg_width) {
|
|
+ case sizeof(u8):
|
|
+ ioread8_rep(addr, buffer, count);
|
|
+ break;
|
|
+ case sizeof(u16):
|
|
+ WARN_ON(count & 1);
|
|
+ ioread16_rep(addr, buffer, count >> 1);
|
|
+ break;
|
|
+ case sizeof(u32):
|
|
+ WARN_ON(count & 3);
|
|
+ ioread32_rep(addr, buffer, count >> 2);
|
|
+ break;
|
|
+ default:
|
|
+ WARN_ON(1);
|
|
+ }
|
|
+}
|
|
+
|
|
+void bcma_host_pci_block_write(struct bcma_device *core, const void *buffer,
|
|
+ size_t count, u16 offset, u8 reg_width)
|
|
+{
|
|
+ void __iomem *addr = core->bus->mmio + offset;
|
|
+ if (core->bus->mapped_core != core)
|
|
+ bcma_host_pci_switch_core(core);
|
|
+ switch (reg_width) {
|
|
+ case sizeof(u8):
|
|
+ iowrite8_rep(addr, buffer, count);
|
|
+ break;
|
|
+ case sizeof(u16):
|
|
+ WARN_ON(count & 1);
|
|
+ iowrite16_rep(addr, buffer, count >> 1);
|
|
+ break;
|
|
+ case sizeof(u32):
|
|
+ WARN_ON(count & 3);
|
|
+ iowrite32_rep(addr, buffer, count >> 2);
|
|
+ break;
|
|
+ default:
|
|
+ WARN_ON(1);
|
|
+ }
|
|
+}
|
|
+#endif
|
|
+
|
|
static u32 bcma_host_pci_aread32(struct bcma_device *core, u16 offset)
|
|
{
|
|
if (core->bus->mapped_core != core)
|
|
@@ -87,6 +135,10 @@ const struct bcma_host_ops bcma_host_pci
|
|
.write8 = bcma_host_pci_write8,
|
|
.write16 = bcma_host_pci_write16,
|
|
.write32 = bcma_host_pci_write32,
|
|
+#ifdef CONFIG_BCMA_BLOCKIO
|
|
+ .block_read = bcma_host_pci_block_read,
|
|
+ .block_write = bcma_host_pci_block_write,
|
|
+#endif
|
|
.aread32 = bcma_host_pci_aread32,
|
|
.awrite32 = bcma_host_pci_awrite32,
|
|
};
|
|
@@ -175,6 +227,7 @@ static DEFINE_PCI_DEVICE_TABLE(bcma_pci_
|
|
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x0576) },
|
|
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4331) },
|
|
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4353) },
|
|
+ { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4357) },
|
|
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4727) },
|
|
{ 0, },
|
|
};
|
|
--- a/drivers/bcma/main.c
|
|
+++ b/drivers/bcma/main.c
|
|
@@ -7,6 +7,7 @@
|
|
|
|
#include "bcma_private.h"
|
|
#include <linux/bcma/bcma.h>
|
|
+#include <linux/slab.h>
|
|
|
|
MODULE_DESCRIPTION("Broadcom's specific AMBA driver");
|
|
MODULE_LICENSE("GPL");
|
|
@@ -89,6 +90,8 @@ static int bcma_register_cores(struct bc
|
|
switch (bus->hosttype) {
|
|
case BCMA_HOSTTYPE_PCI:
|
|
core->dev.parent = &bus->host_pci->dev;
|
|
+ core->dma_dev = &bus->host_pci->dev;
|
|
+ core->irq = bus->host_pci->irq;
|
|
break;
|
|
case BCMA_HOSTTYPE_NONE:
|
|
case BCMA_HOSTTYPE_SDIO:
|
|
@@ -144,6 +147,15 @@ int bcma_bus_register(struct bcma_bus *b
|
|
bcma_core_pci_init(&bus->drv_pci);
|
|
}
|
|
|
|
+ /* Try to get SPROM */
|
|
+ err = bcma_sprom_get(bus);
|
|
+ if (err == -ENOENT) {
|
|
+ pr_err("No SPROM available\n");
|
|
+ } else if (err) {
|
|
+ pr_err("Failed to get SPROM: %d\n", err);
|
|
+ return -ENOENT;
|
|
+ }
|
|
+
|
|
/* Register found cores */
|
|
bcma_register_cores(bus);
|
|
|
|
@@ -151,13 +163,11 @@ int bcma_bus_register(struct bcma_bus *b
|
|
|
|
return 0;
|
|
}
|
|
-EXPORT_SYMBOL_GPL(bcma_bus_register);
|
|
|
|
void bcma_bus_unregister(struct bcma_bus *bus)
|
|
{
|
|
bcma_unregister_cores(bus);
|
|
}
|
|
-EXPORT_SYMBOL_GPL(bcma_bus_unregister);
|
|
|
|
int __bcma_driver_register(struct bcma_driver *drv, struct module *owner)
|
|
{
|
|
--- /dev/null
|
|
+++ b/drivers/bcma/sprom.c
|
|
@@ -0,0 +1,171 @@
|
|
+/*
|
|
+ * Broadcom specific AMBA
|
|
+ * SPROM reading
|
|
+ *
|
|
+ * Licensed under the GNU/GPL. See COPYING for details.
|
|
+ */
|
|
+
|
|
+#include "bcma_private.h"
|
|
+
|
|
+#include <linux/bcma/bcma.h>
|
|
+#include <linux/bcma/bcma_regs.h>
|
|
+#include <linux/pci.h>
|
|
+#include <linux/io.h>
|
|
+#include <linux/dma-mapping.h>
|
|
+#include <linux/slab.h>
|
|
+
|
|
+#define SPOFF(offset) ((offset) / sizeof(u16))
|
|
+
|
|
+/**************************************************
|
|
+ * R/W ops.
|
|
+ **************************************************/
|
|
+
|
|
+static void bcma_sprom_read(struct bcma_bus *bus, u16 offset, u16 *sprom)
|
|
+{
|
|
+ int i;
|
|
+ for (i = 0; i < SSB_SPROMSIZE_WORDS_R4; i++)
|
|
+ sprom[i] = bcma_read16(bus->drv_cc.core,
|
|
+ offset + (i * 2));
|
|
+}
|
|
+
|
|
+/**************************************************
|
|
+ * Validation.
|
|
+ **************************************************/
|
|
+
|
|
+static inline u8 bcma_crc8(u8 crc, u8 data)
|
|
+{
|
|
+ /* Polynomial: x^8 + x^7 + x^6 + x^4 + x^2 + 1 */
|
|
+ static const u8 t[] = {
|
|
+ 0x00, 0xF7, 0xB9, 0x4E, 0x25, 0xD2, 0x9C, 0x6B,
|
|
+ 0x4A, 0xBD, 0xF3, 0x04, 0x6F, 0x98, 0xD6, 0x21,
|
|
+ 0x94, 0x63, 0x2D, 0xDA, 0xB1, 0x46, 0x08, 0xFF,
|
|
+ 0xDE, 0x29, 0x67, 0x90, 0xFB, 0x0C, 0x42, 0xB5,
|
|
+ 0x7F, 0x88, 0xC6, 0x31, 0x5A, 0xAD, 0xE3, 0x14,
|
|
+ 0x35, 0xC2, 0x8C, 0x7B, 0x10, 0xE7, 0xA9, 0x5E,
|
|
+ 0xEB, 0x1C, 0x52, 0xA5, 0xCE, 0x39, 0x77, 0x80,
|
|
+ 0xA1, 0x56, 0x18, 0xEF, 0x84, 0x73, 0x3D, 0xCA,
|
|
+ 0xFE, 0x09, 0x47, 0xB0, 0xDB, 0x2C, 0x62, 0x95,
|
|
+ 0xB4, 0x43, 0x0D, 0xFA, 0x91, 0x66, 0x28, 0xDF,
|
|
+ 0x6A, 0x9D, 0xD3, 0x24, 0x4F, 0xB8, 0xF6, 0x01,
|
|
+ 0x20, 0xD7, 0x99, 0x6E, 0x05, 0xF2, 0xBC, 0x4B,
|
|
+ 0x81, 0x76, 0x38, 0xCF, 0xA4, 0x53, 0x1D, 0xEA,
|
|
+ 0xCB, 0x3C, 0x72, 0x85, 0xEE, 0x19, 0x57, 0xA0,
|
|
+ 0x15, 0xE2, 0xAC, 0x5B, 0x30, 0xC7, 0x89, 0x7E,
|
|
+ 0x5F, 0xA8, 0xE6, 0x11, 0x7A, 0x8D, 0xC3, 0x34,
|
|
+ 0xAB, 0x5C, 0x12, 0xE5, 0x8E, 0x79, 0x37, 0xC0,
|
|
+ 0xE1, 0x16, 0x58, 0xAF, 0xC4, 0x33, 0x7D, 0x8A,
|
|
+ 0x3F, 0xC8, 0x86, 0x71, 0x1A, 0xED, 0xA3, 0x54,
|
|
+ 0x75, 0x82, 0xCC, 0x3B, 0x50, 0xA7, 0xE9, 0x1E,
|
|
+ 0xD4, 0x23, 0x6D, 0x9A, 0xF1, 0x06, 0x48, 0xBF,
|
|
+ 0x9E, 0x69, 0x27, 0xD0, 0xBB, 0x4C, 0x02, 0xF5,
|
|
+ 0x40, 0xB7, 0xF9, 0x0E, 0x65, 0x92, 0xDC, 0x2B,
|
|
+ 0x0A, 0xFD, 0xB3, 0x44, 0x2F, 0xD8, 0x96, 0x61,
|
|
+ 0x55, 0xA2, 0xEC, 0x1B, 0x70, 0x87, 0xC9, 0x3E,
|
|
+ 0x1F, 0xE8, 0xA6, 0x51, 0x3A, 0xCD, 0x83, 0x74,
|
|
+ 0xC1, 0x36, 0x78, 0x8F, 0xE4, 0x13, 0x5D, 0xAA,
|
|
+ 0x8B, 0x7C, 0x32, 0xC5, 0xAE, 0x59, 0x17, 0xE0,
|
|
+ 0x2A, 0xDD, 0x93, 0x64, 0x0F, 0xF8, 0xB6, 0x41,
|
|
+ 0x60, 0x97, 0xD9, 0x2E, 0x45, 0xB2, 0xFC, 0x0B,
|
|
+ 0xBE, 0x49, 0x07, 0xF0, 0x9B, 0x6C, 0x22, 0xD5,
|
|
+ 0xF4, 0x03, 0x4D, 0xBA, 0xD1, 0x26, 0x68, 0x9F,
|
|
+ };
|
|
+ return t[crc ^ data];
|
|
+}
|
|
+
|
|
+static u8 bcma_sprom_crc(const u16 *sprom)
|
|
+{
|
|
+ int word;
|
|
+ u8 crc = 0xFF;
|
|
+
|
|
+ for (word = 0; word < SSB_SPROMSIZE_WORDS_R4 - 1; word++) {
|
|
+ crc = bcma_crc8(crc, sprom[word] & 0x00FF);
|
|
+ crc = bcma_crc8(crc, (sprom[word] & 0xFF00) >> 8);
|
|
+ }
|
|
+ crc = bcma_crc8(crc, sprom[SSB_SPROMSIZE_WORDS_R4 - 1] & 0x00FF);
|
|
+ crc ^= 0xFF;
|
|
+
|
|
+ return crc;
|
|
+}
|
|
+
|
|
+static int bcma_sprom_check_crc(const u16 *sprom)
|
|
+{
|
|
+ u8 crc;
|
|
+ u8 expected_crc;
|
|
+ u16 tmp;
|
|
+
|
|
+ crc = bcma_sprom_crc(sprom);
|
|
+ tmp = sprom[SSB_SPROMSIZE_WORDS_R4 - 1] & SSB_SPROM_REVISION_CRC;
|
|
+ expected_crc = tmp >> SSB_SPROM_REVISION_CRC_SHIFT;
|
|
+ if (crc != expected_crc)
|
|
+ return -EPROTO;
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int bcma_sprom_valid(const u16 *sprom)
|
|
+{
|
|
+ u16 revision;
|
|
+ int err;
|
|
+
|
|
+ err = bcma_sprom_check_crc(sprom);
|
|
+ if (err)
|
|
+ return err;
|
|
+
|
|
+ revision = sprom[SSB_SPROMSIZE_WORDS_R4 - 1] & SSB_SPROM_REVISION_REV;
|
|
+ if (revision != 8 && revision != 9) {
|
|
+ pr_err("Unsupported SPROM revision: %d\n", revision);
|
|
+ return -ENOENT;
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+/**************************************************
|
|
+ * SPROM extraction.
|
|
+ **************************************************/
|
|
+
|
|
+static void bcma_sprom_extract_r8(struct bcma_bus *bus, const u16 *sprom)
|
|
+{
|
|
+ u16 v;
|
|
+ int i;
|
|
+
|
|
+ for (i = 0; i < 3; i++) {
|
|
+ v = sprom[SPOFF(SSB_SPROM8_IL0MAC) + i];
|
|
+ *(((__be16 *)bus->sprom.il0mac) + i) = cpu_to_be16(v);
|
|
+ }
|
|
+}
|
|
+
|
|
+int bcma_sprom_get(struct bcma_bus *bus)
|
|
+{
|
|
+ u16 offset;
|
|
+ u16 *sprom;
|
|
+ int err = 0;
|
|
+
|
|
+ if (!bus->drv_cc.core)
|
|
+ return -EOPNOTSUPP;
|
|
+
|
|
+ if (!(bus->drv_cc.capabilities & BCMA_CC_CAP_SPROM))
|
|
+ return -ENOENT;
|
|
+
|
|
+ sprom = kcalloc(SSB_SPROMSIZE_WORDS_R4, sizeof(u16),
|
|
+ GFP_KERNEL);
|
|
+ if (!sprom)
|
|
+ return -ENOMEM;
|
|
+
|
|
+ /* Most cards have SPROM moved by additional offset 0x30 (48 dwords).
|
|
+ * According to brcm80211 this applies to cards with PCIe rev >= 6
|
|
+ * TODO: understand this condition and use it */
|
|
+ offset = (bus->chipinfo.id == 0x4331) ? BCMA_CC_SPROM :
|
|
+ BCMA_CC_SPROM_PCIE6;
|
|
+ bcma_sprom_read(bus, offset, sprom);
|
|
+
|
|
+ err = bcma_sprom_valid(sprom);
|
|
+ if (err)
|
|
+ goto out;
|
|
+
|
|
+ bcma_sprom_extract_r8(bus, sprom);
|
|
+
|
|
+out:
|
|
+ kfree(sprom);
|
|
+ return err;
|
|
+}
|
|
--- a/include/linux/bcma/bcma.h
|
|
+++ b/include/linux/bcma/bcma.h
|
|
@@ -6,6 +6,7 @@
|
|
|
|
#include <linux/bcma/bcma_driver_chipcommon.h>
|
|
#include <linux/bcma/bcma_driver_pci.h>
|
|
+#include <linux/ssb/ssb.h> /* SPROM sharing */
|
|
|
|
#include "bcma_regs.h"
|
|
|
|
@@ -24,6 +25,11 @@ struct bcma_chipinfo {
|
|
u8 pkg;
|
|
};
|
|
|
|
+enum bcma_clkmode {
|
|
+ BCMA_CLKMODE_FAST,
|
|
+ BCMA_CLKMODE_DYNAMIC,
|
|
+};
|
|
+
|
|
struct bcma_host_ops {
|
|
u8 (*read8)(struct bcma_device *core, u16 offset);
|
|
u16 (*read16)(struct bcma_device *core, u16 offset);
|
|
@@ -31,6 +37,12 @@ struct bcma_host_ops {
|
|
void (*write8)(struct bcma_device *core, u16 offset, u8 value);
|
|
void (*write16)(struct bcma_device *core, u16 offset, u16 value);
|
|
void (*write32)(struct bcma_device *core, u16 offset, u32 value);
|
|
+#ifdef CONFIG_BCMA_BLOCKIO
|
|
+ void (*block_read)(struct bcma_device *core, void *buffer,
|
|
+ size_t count, u16 offset, u8 reg_width);
|
|
+ void (*block_write)(struct bcma_device *core, const void *buffer,
|
|
+ size_t count, u16 offset, u8 reg_width);
|
|
+#endif
|
|
/* Agent ops */
|
|
u32 (*aread32)(struct bcma_device *core, u16 offset);
|
|
void (*awrite32)(struct bcma_device *core, u16 offset, u32 value);
|
|
@@ -117,6 +129,8 @@ struct bcma_device {
|
|
struct bcma_device_id id;
|
|
|
|
struct device dev;
|
|
+ struct device *dma_dev;
|
|
+ unsigned int irq;
|
|
bool dev_registered;
|
|
|
|
u8 core_index;
|
|
@@ -179,6 +193,10 @@ struct bcma_bus {
|
|
|
|
struct bcma_drv_cc drv_cc;
|
|
struct bcma_drv_pci drv_pci;
|
|
+
|
|
+ /* We decided to share SPROM struct with SSB as long as we do not need
|
|
+ * any hacks for BCMA. This simplifies drivers code. */
|
|
+ struct ssb_sprom sprom;
|
|
};
|
|
|
|
extern inline u32 bcma_read8(struct bcma_device *core, u16 offset)
|
|
@@ -208,6 +226,18 @@ void bcma_write32(struct bcma_device *co
|
|
{
|
|
core->bus->ops->write32(core, offset, value);
|
|
}
|
|
+#ifdef CONFIG_BCMA_BLOCKIO
|
|
+extern inline void bcma_block_read(struct bcma_device *core, void *buffer,
|
|
+ size_t count, u16 offset, u8 reg_width)
|
|
+{
|
|
+ core->bus->ops->block_read(core, buffer, count, offset, reg_width);
|
|
+}
|
|
+extern inline void bcma_block_write(struct bcma_device *core, const void *buffer,
|
|
+ size_t count, u16 offset, u8 reg_width)
|
|
+{
|
|
+ core->bus->ops->block_write(core, buffer, count, offset, reg_width);
|
|
+}
|
|
+#endif
|
|
extern inline u32 bcma_aread32(struct bcma_device *core, u16 offset)
|
|
{
|
|
return core->bus->ops->aread32(core, offset);
|
|
@@ -218,7 +248,24 @@ void bcma_awrite32(struct bcma_device *c
|
|
core->bus->ops->awrite32(core, offset, value);
|
|
}
|
|
|
|
+#define bcma_mask32(cc, offset, mask) \
|
|
+ bcma_write32(cc, offset, bcma_read32(cc, offset) & (mask))
|
|
+#define bcma_set32(cc, offset, set) \
|
|
+ bcma_write32(cc, offset, bcma_read32(cc, offset) | (set))
|
|
+#define bcma_maskset32(cc, offset, mask, set) \
|
|
+ bcma_write32(cc, offset, (bcma_read32(cc, offset) & (mask)) | (set))
|
|
+
|
|
extern bool bcma_core_is_enabled(struct bcma_device *core);
|
|
+extern void bcma_core_disable(struct bcma_device *core, u32 flags);
|
|
extern int bcma_core_enable(struct bcma_device *core, u32 flags);
|
|
+extern void bcma_core_set_clockmode(struct bcma_device *core,
|
|
+ enum bcma_clkmode clkmode);
|
|
+extern void bcma_core_pll_ctl(struct bcma_device *core, u32 req, u32 status,
|
|
+ bool on);
|
|
+#define BCMA_DMA_TRANSLATION_MASK 0xC0000000
|
|
+#define BCMA_DMA_TRANSLATION_NONE 0x00000000
|
|
+#define BCMA_DMA_TRANSLATION_DMA32_CMT 0x40000000 /* Client Mode Translation for 32-bit DMA */
|
|
+#define BCMA_DMA_TRANSLATION_DMA64_CMT 0x80000000 /* Client Mode Translation for 64-bit DMA */
|
|
+extern u32 bcma_core_dma_translation(struct bcma_device *core);
|
|
|
|
#endif /* LINUX_BCMA_H_ */
|
|
--- a/include/linux/bcma/bcma_driver_chipcommon.h
|
|
+++ b/include/linux/bcma/bcma_driver_chipcommon.h
|
|
@@ -179,15 +179,7 @@
|
|
#define BCMA_CC_PROG_WAITCNT 0x0124
|
|
#define BCMA_CC_FLASH_CFG 0x0128
|
|
#define BCMA_CC_FLASH_WAITCNT 0x012C
|
|
-#define BCMA_CC_CLKCTLST 0x01E0 /* Clock control and status (rev >= 20) */
|
|
-#define BCMA_CC_CLKCTLST_FORCEALP 0x00000001 /* Force ALP request */
|
|
-#define BCMA_CC_CLKCTLST_FORCEHT 0x00000002 /* Force HT request */
|
|
-#define BCMA_CC_CLKCTLST_FORCEILP 0x00000004 /* Force ILP request */
|
|
-#define BCMA_CC_CLKCTLST_HAVEALPREQ 0x00000008 /* ALP available request */
|
|
-#define BCMA_CC_CLKCTLST_HAVEHTREQ 0x00000010 /* HT available request */
|
|
-#define BCMA_CC_CLKCTLST_HWCROFF 0x00000020 /* Force HW clock request off */
|
|
-#define BCMA_CC_CLKCTLST_HAVEHT 0x00010000 /* HT available */
|
|
-#define BCMA_CC_CLKCTLST_HAVEALP 0x00020000 /* APL available */
|
|
+/* 0x1E0 is defined as shared BCMA_CLKCTLST */
|
|
#define BCMA_CC_HW_WORKAROUND 0x01E4 /* Hardware workaround (rev >= 20) */
|
|
#define BCMA_CC_UART0_DATA 0x0300
|
|
#define BCMA_CC_UART0_IMR 0x0304
|
|
@@ -244,6 +236,8 @@
|
|
#define BCMA_CC_REGCTL_DATA 0x065C
|
|
#define BCMA_CC_PLLCTL_ADDR 0x0660
|
|
#define BCMA_CC_PLLCTL_DATA 0x0664
|
|
+#define BCMA_CC_SPROM 0x0800 /* SPROM beginning */
|
|
+#define BCMA_CC_SPROM_PCIE6 0x0830 /* SPROM beginning on PCIe rev >= 6 */
|
|
|
|
/* Data for the PMU, if available.
|
|
* Check availability with ((struct bcma_chipcommon)->capabilities & BCMA_CC_CAP_PMU)
|
|
--- a/include/linux/bcma/bcma_driver_pci.h
|
|
+++ b/include/linux/bcma/bcma_driver_pci.h
|
|
@@ -85,5 +85,7 @@ struct bcma_drv_pci {
|
|
#define pcicore_write32(pc, offset, val) bcma_write32((pc)->core, offset, val)
|
|
|
|
extern void bcma_core_pci_init(struct bcma_drv_pci *pc);
|
|
+extern int bcma_core_pci_irq_ctl(struct bcma_drv_pci *pc,
|
|
+ struct bcma_device *core, bool enable);
|
|
|
|
#endif /* LINUX_BCMA_DRIVER_PCI_H_ */
|
|
--- a/drivers/bcma/driver_chipcommon.c
|
|
+++ b/drivers/bcma/driver_chipcommon.c
|
|
@@ -23,6 +23,9 @@ static inline u32 bcma_cc_write32_masked
|
|
|
|
void bcma_core_chipcommon_init(struct bcma_drv_cc *cc)
|
|
{
|
|
+ u32 leddc_on = 10;
|
|
+ u32 leddc_off = 90;
|
|
+
|
|
if (cc->core->id.rev >= 11)
|
|
cc->status = bcma_cc_read32(cc, BCMA_CC_CHIPSTAT);
|
|
cc->capabilities = bcma_cc_read32(cc, BCMA_CC_CAP);
|
|
@@ -38,6 +41,17 @@ void bcma_core_chipcommon_init(struct bc
|
|
bcma_pmu_init(cc);
|
|
if (cc->capabilities & BCMA_CC_CAP_PCTL)
|
|
pr_err("Power control not implemented!\n");
|
|
+
|
|
+ if (cc->core->id.rev >= 16) {
|
|
+ if (cc->core->bus->sprom.leddc_on_time &&
|
|
+ cc->core->bus->sprom.leddc_off_time) {
|
|
+ leddc_on = cc->core->bus->sprom.leddc_on_time;
|
|
+ leddc_off = cc->core->bus->sprom.leddc_off_time;
|
|
+ }
|
|
+ bcma_cc_write32(cc, BCMA_CC_GPIOTIMER,
|
|
+ ((leddc_on << BCMA_CC_GPIOTIMER_ONTIME_SHIFT) |
|
|
+ (leddc_off << BCMA_CC_GPIOTIMER_OFFTIME_SHIFT)));
|
|
+ }
|
|
}
|
|
|
|
/* Set chip watchdog reset timer to fire in 'ticks' backplane cycles */
|
|
--- /dev/null
|
|
+++ b/drivers/bcma/driver_pci_host.c
|
|
@@ -0,0 +1,14 @@
|
|
+/*
|
|
+ * Broadcom specific AMBA
|
|
+ * PCI Core in hostmode
|
|
+ *
|
|
+ * Licensed under the GNU/GPL. See COPYING for details.
|
|
+ */
|
|
+
|
|
+#include "bcma_private.h"
|
|
+#include <linux/bcma/bcma.h>
|
|
+
|
|
+void bcma_core_pci_hostmode_init(struct bcma_drv_pci *pc)
|
|
+{
|
|
+ pr_err("No support for PCI core in hostmode yet\n");
|
|
+}
|
|
--- a/include/linux/bcma/bcma_regs.h
|
|
+++ b/include/linux/bcma/bcma_regs.h
|
|
@@ -1,13 +1,38 @@
|
|
#ifndef LINUX_BCMA_REGS_H_
|
|
#define LINUX_BCMA_REGS_H_
|
|
|
|
+/* Some single registers are shared between many cores */
|
|
+/* BCMA_CLKCTLST: ChipCommon (rev >= 20), PCIe, 80211 */
|
|
+#define BCMA_CLKCTLST 0x01E0 /* Clock control and status */
|
|
+#define BCMA_CLKCTLST_FORCEALP 0x00000001 /* Force ALP request */
|
|
+#define BCMA_CLKCTLST_FORCEHT 0x00000002 /* Force HT request */
|
|
+#define BCMA_CLKCTLST_FORCEILP 0x00000004 /* Force ILP request */
|
|
+#define BCMA_CLKCTLST_HAVEALPREQ 0x00000008 /* ALP available request */
|
|
+#define BCMA_CLKCTLST_HAVEHTREQ 0x00000010 /* HT available request */
|
|
+#define BCMA_CLKCTLST_HWCROFF 0x00000020 /* Force HW clock request off */
|
|
+#define BCMA_CLKCTLST_EXTRESREQ 0x00000700 /* Mask of external resource requests */
|
|
+#define BCMA_CLKCTLST_HAVEALP 0x00010000 /* ALP available */
|
|
+#define BCMA_CLKCTLST_HAVEHT 0x00020000 /* HT available */
|
|
+#define BCMA_CLKCTLST_BP_ON_ALP 0x00040000 /* RO: running on ALP clock */
|
|
+#define BCMA_CLKCTLST_BP_ON_HT 0x00080000 /* RO: running on HT clock */
|
|
+#define BCMA_CLKCTLST_EXTRESST 0x07000000 /* Mask of external resource status */
|
|
+/* Is there any BCM4328 on BCMA bus? */
|
|
+#define BCMA_CLKCTLST_4328A0_HAVEHT 0x00010000 /* 4328a0 has reversed bits */
|
|
+#define BCMA_CLKCTLST_4328A0_HAVEALP 0x00020000 /* 4328a0 has reversed bits */
|
|
+
|
|
/* Agent registers (common for every core) */
|
|
-#define BCMA_IOCTL 0x0408
|
|
+#define BCMA_IOCTL 0x0408 /* IO control */
|
|
#define BCMA_IOCTL_CLK 0x0001
|
|
#define BCMA_IOCTL_FGC 0x0002
|
|
#define BCMA_IOCTL_CORE_BITS 0x3FFC
|
|
#define BCMA_IOCTL_PME_EN 0x4000
|
|
#define BCMA_IOCTL_BIST_EN 0x8000
|
|
+#define BCMA_IOST 0x0500 /* IO status */
|
|
+#define BCMA_IOST_CORE_BITS 0x0FFF
|
|
+#define BCMA_IOST_DMA64 0x1000
|
|
+#define BCMA_IOST_GATED_CLK 0x2000
|
|
+#define BCMA_IOST_BIST_ERROR 0x4000
|
|
+#define BCMA_IOST_BIST_DONE 0x8000
|
|
#define BCMA_RESET_CTL 0x0800
|
|
#define BCMA_RESET_CTL_RESET 0x0001
|
|
|