1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-15 17:53:10 +03:00
openwrt-xburst/package/madwifi/patches/106-get_arch.patch
nbd 7e7cdddf8d madwifi: fix x86_64 compilation
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12574 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-09-12 19:55:38 +00:00

17 lines
302 B
Diff

--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
@@ -36,6 +36,13 @@
$(Cannot determine ARCH)
endif
+# Allow ARCH to be x86
+ifneq (,$(CONFIG_X86))
+ifeq (x86,$(ARCH))
+ARCH-y = $(ARCH)
+endif
+endif
+
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)