1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 02:07:37 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
juhosg d5b89889f8 [kernel] generic-2.6/2.6.30: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15981 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-05-22 09:46:02 +00:00

26 lines
534 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -784,6 +784,8 @@ config CRYPTO_ANSI_CPRNG
for cryptographic modules. Uses the Algorithm specified in
ANSI X9.31 A.2.4
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o