1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-03 11:04:37 +03:00
openwrt-xburst/target/linux/ramips/patches-2.6.32/103-ethernet.patch
juhosg c6fd9710b6 ramips: add preliminary support for 2.6.32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19343 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-01-26 09:57:38 +00:00

26 lines
837 B
Diff

--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -602,6 +602,12 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
+config MIPS_RAMIPS_NET
+ tristate "Ethernet driver for rt288x/rt305x"
+ depends on MIPS_RALINK
+ help
+ This driver supports the etehrnet mac inside the ralink wisocs
+
config SGI_IOC3_ETH
bool "SGI IOC3 Ethernet"
depends on PCI && SGI_IP27
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -217,6 +217,7 @@ obj-$(CONFIG_KORINA) += korina.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
+obj-$(CONFIG_MIPS_RAMIPS_NET) += ramips.o
obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
obj-$(CONFIG_DECLANCE) += declance.o
obj-$(CONFIG_ATARILANCE) += atarilance.o