mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-06 15:27:11 +02:00
567f8df77e
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12364 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
594 B
Diff
25 lines
594 B
Diff
--- a/drivers/ide/Kconfig
|
|
+++ b/drivers/ide/Kconfig
|
|
@@ -928,6 +928,14 @@
|
|
|
|
If unsure, say N.
|
|
|
|
+config BLK_DEV_MAGICBOX_IDE
|
|
+ tristate "MagicBox 2.0 CF IDE support"
|
|
+ depends on 4xx && IDE
|
|
+ help
|
|
+ This option provides support for IDE on MagicBox 2.0 boards.
|
|
+
|
|
+ If unsure, say N.
|
|
+
|
|
choice
|
|
prompt "Type of MPC8xx IDE interface"
|
|
depends on BLK_DEV_MPC8xx_IDE
|
|
--- a/drivers/ide/ppc/Makefile
|
|
+++ b/drivers/ide/ppc/Makefile
|
|
@@ -1,3 +1,4 @@
|
|
|
|
obj-$(CONFIG_BLK_DEV_IDE_PMAC) += pmac.o
|
|
obj-$(CONFIG_BLK_DEV_MPC8xx_IDE) += mpc8xx.o
|
|
+obj-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += magicbox_ide.o
|