mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:20:37 +02:00
487bc0ebd7
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28392 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
706 B
Diff
28 lines
706 B
Diff
--- a/drivers/net/wireless/ath/Makefile
|
|
+++ b/drivers/net/wireless/ath/Makefile
|
|
@@ -8,6 +8,5 @@ obj-$(CONFIG_ATH_COMMON) += ath.o
|
|
ath-objs := main.o \
|
|
regd.o \
|
|
hw.o \
|
|
- key.o
|
|
-
|
|
-ath-$(CONFIG_ATH_DEBUG) += debug.o
|
|
+ key.o \
|
|
+ debug.o
|
|
--- a/drivers/net/wireless/ath/ath.h
|
|
+++ b/drivers/net/wireless/ath/ath.h
|
|
@@ -272,13 +272,6 @@ void ath_dbg(struct ath_common *common,
|
|
#endif /* CONFIG_ATH_DEBUG */
|
|
|
|
/** Returns string describing opmode, or NULL if unknown mode. */
|
|
-#ifdef CONFIG_ATH_DEBUG
|
|
const char *ath_opmode_to_string(enum nl80211_iftype opmode);
|
|
-#else
|
|
-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
|
|
-{
|
|
- return "UNKNOWN";
|
|
-}
|
|
-#endif
|
|
|
|
#endif /* ATH_H */
|