1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 19:57:09 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/120-rb153_cf_driver.patch
juhosg a7f49cd3e8 [adm5120] new experimental driver for the CF slot on the RouterBOARD 153
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9707 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-12-11 09:00:06 +00:00

27 lines
907 B
Diff

--- linux-2.6.23.9/drivers/ata/Makefile.orig 2007-11-26 18:51:43.000000000 +0100
+++ linux-2.6.23.9/drivers/ata/Makefile 2007-12-08 18:15:07.000000000 +0100
@@ -63,6 +63,7 @@
obj-$(CONFIG_PATA_SCC) += pata_scc.o
obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
obj-$(CONFIG_PATA_ICSIDE) += pata_icside.o
+obj-$(CONFIG_PATA_RB153_CF) += pata_rb153_cf.o
# Should be last but one libata driver
obj-$(CONFIG_ATA_GENERIC) += ata_generic.o
# Should be last libata driver
--- linux-2.6.23.9/drivers/ata/Kconfig.orig 2007-11-26 18:51:43.000000000 +0100
+++ linux-2.6.23.9/drivers/ata/Kconfig 2007-12-08 18:16:43.000000000 +0100
@@ -596,4 +596,13 @@
If unsure, say N.
+config PATA_RB153_CF
+ tristate "RouterBOARD 153 Compact Flash support"
+ depends on MIPS_ADM5120
+ help
+ This option enables support for a Compact Flash connected on
+ the RouterBOARD 153.
+
+ If unsure, say N.
+
endif # ATA