mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
c5552ad039
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21952 3c298f89-4303-0410-b956-a3cf2f4a3e73
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
Upstream doesn't optimize the kernel and bootwrappers for ppc44x because
|
|
they still want to support gcc 3.3 -- well, we don't.
|
|
|
|
--- a/arch/powerpc/Makefile
|
|
+++ b/arch/powerpc/Makefile
|
|
@@ -123,7 +123,8 @@ ifeq ($(CONFIG_FUNCTION_TRACER),y)
|
|
KBUILD_CFLAGS += -mno-sched-epilog
|
|
endif
|
|
|
|
-cpu-as-$(CONFIG_4xx) += -Wa,-m405
|
|
+cpu-as-$(CONFIG_40x) += -Wa,-m405
|
|
+cpu-as-$(CONFIG_44x) += -Wa,-m440
|
|
cpu-as-$(CONFIG_6xx) += -Wa,-maltivec
|
|
cpu-as-$(CONFIG_POWER4) += -Wa,-maltivec
|
|
cpu-as-$(CONFIG_E500) += -Wa,-me500
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -38,10 +38,10 @@ BOOTCFLAGS += -I$(obj) -I$(srctree)/$(ob
|
|
DTS_FLAGS ?= -p 1024
|
|
|
|
$(obj)/4xx.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/ebony.o: BOOTCFLAGS += -mcpu=405
|
|
+$(obj)/ebony.o: BOOTCFLAGS += -mcpu=440
|
|
$(obj)/cuboot-hotfoot.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=405
|
|
-$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=405
|
|
+$(obj)/cuboot-taishan.o: BOOTCFLAGS += -mcpu=440
|
|
+$(obj)/cuboot-katmai.o: BOOTCFLAGS += -mcpu=440
|
|
$(obj)/cuboot-acadia.o: BOOTCFLAGS += -mcpu=405
|
|
$(obj)/treeboot-walnut.o: BOOTCFLAGS += -mcpu=405
|
|
$(obj)/virtex405-head.o: BOOTAFLAGS += -mcpu=405
|