1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-02 07:22:54 +03:00
openwrt-xburst/target/linux/atheros/patches-2.6.27/130-ar2313_ethernet.patch
juhosg eecd8cc2a3 [atheros] experimental support for 2.6.27
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12932 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-10-09 08:08:13 +00:00

26 lines
749 B
Diff

--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -359,6 +359,12 @@
help
Select this if your platform comes with an external 93CX6 eeprom.
+config AR2313
+ tristate "AR2313 Ethernet support"
+ depends on NET_ETHERNET && ATHEROS
+ help
+ Support for the AR231x/531x ethernet controller
+
config MACE
tristate "MACE (Power Mac ethernet) support"
depends on PPC_PMAC && PPC32
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
@@ -195,6 +195,7 @@
obj-$(CONFIG_KORINA) += korina.o
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
+obj-$(CONFIG_AR2313) += ar2313/
obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
obj-$(CONFIG_DECLANCE) += declance.o