1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-17 10:20:37 +03:00
openwrt-xburst/package/opkg/patches/004-host_cpu.patch
kaloz dbf38e7683 upgrade opkg to r215 from the googlecode svn
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17152 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-08-06 20:08:27 +00:00

21 lines
973 B
Diff

--- a/libbb/Makefile.am
+++ b/libbb/Makefile.am
@@ -1,6 +1,6 @@
HOST_CPU=@host_cpu@
BUILD_CPU=@build_cpu@
-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@
noinst_LTLIBRARIES = libbb.la
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -1,5 +1,5 @@
-
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
+HOST_CPU=@host_cpu@
+AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DOPKGETCDIR=\"@opkgetcdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
libopkg_includedir=$(includedir)/libopkg
libopkg_include_HEADERS= opkg.h