mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:02:50 +02:00
efde7ff8e6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8110 3c298f89-4303-0410-b956-a3cf2f4a3e73
381 lines
9.0 KiB
Diff
381 lines
9.0 KiB
Diff
Index: madwifi-ng-r2568-20070710/tools/80211debug.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/80211debug.c 2007-07-23 01:48:38.846193887 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/80211debug.c 2007-07-23 01:48:39.578235605 +0200
|
|
@@ -49,6 +49,10 @@
|
|
#include <getopt.h>
|
|
#include <err.h>
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
#define N(a) (sizeof(a)/sizeof(a[0]))
|
|
|
|
const char *progname;
|
|
@@ -180,9 +184,19 @@
|
|
}
|
|
#endif /* __linux__ */
|
|
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+a80211debug_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
const char *ifname = "ath0";
|
|
const char *cp, *tp;
|
|
const char *sep;
|
|
Index: madwifi-ng-r2568-20070710/tools/80211stats.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/80211stats.c 2007-07-23 01:48:38.854194346 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/80211stats.c 2007-07-23 01:48:39.578235605 +0200
|
|
@@ -60,6 +60,10 @@
|
|
#include "net80211/ieee80211_crypto.h"
|
|
#include "net80211/ieee80211_ioctl.h"
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
#ifndef SIOCG80211STATS
|
|
#define SIOCG80211STATS (SIOCDEVPRIVATE + 2)
|
|
#endif
|
|
@@ -243,9 +247,19 @@
|
|
#undef STAT
|
|
}
|
|
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+a80211stats_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
int c, len;
|
|
struct ieee80211req_sta_info *si;
|
|
u_int8_t buf[24*1024], *cp;
|
|
Index: madwifi-ng-r2568-20070710/tools/athchans.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/athchans.c 2007-07-23 01:48:38.858194572 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/athchans.c 2007-07-23 01:48:39.598236745 +0200
|
|
@@ -59,6 +59,10 @@
|
|
#include "net80211/ieee80211_crypto.h"
|
|
#include "net80211/ieee80211_ioctl.h"
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
static int s = -1;
|
|
const char *progname;
|
|
|
|
@@ -138,9 +142,20 @@
|
|
}
|
|
|
|
#define MAXCHAN ((int)(sizeof(struct ieee80211req_chanlist) * NBBY))
|
|
+
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+athchans_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
const char *ifname = "wifi0";
|
|
struct ieee80211req_chanlist chanlist;
|
|
int c;
|
|
Index: madwifi-ng-r2568-20070710/tools/athctrl.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/athctrl.c 2007-07-23 01:48:38.866195027 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/athctrl.c 2007-07-23 01:48:39.626238340 +0200
|
|
@@ -53,6 +53,10 @@
|
|
|
|
#include <net/if.h>
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
static int
|
|
setsysctrl(const char *dev, const char *control , u_long value)
|
|
{
|
|
@@ -87,9 +91,19 @@
|
|
exit(1);
|
|
}
|
|
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+athctrl_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
char device[IFNAMSIZ + 1];
|
|
int distance = -1;
|
|
int c;
|
|
Index: madwifi-ng-r2568-20070710/tools/athdebug.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/athdebug.c 2007-07-23 01:48:38.874195486 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/athdebug.c 2007-07-23 01:48:39.650239706 +0200
|
|
@@ -52,6 +52,10 @@
|
|
#include <getopt.h>
|
|
#include <err.h>
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
#define N(a) (sizeof(a)/sizeof(a[0]))
|
|
|
|
const char *progname;
|
|
@@ -179,9 +183,20 @@
|
|
}
|
|
#endif /* __linux__ */
|
|
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+athdebug_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
+
|
|
#ifdef __linux__
|
|
const char *ifname = "wifi0";
|
|
#else
|
|
Index: madwifi-ng-r2568-20070710/tools/athkey.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/athkey.c 2007-07-23 01:48:38.878195712 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/athkey.c 2007-07-23 01:48:39.698242443 +0200
|
|
@@ -59,6 +59,10 @@
|
|
#include "net80211/ieee80211_crypto.h"
|
|
#include "net80211/ieee80211_ioctl.h"
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
static int s = -1;
|
|
const char *progname;
|
|
|
|
@@ -211,9 +215,19 @@
|
|
exit(-1);
|
|
}
|
|
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+athkey_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
const char *ifname = "wifi0";
|
|
struct ieee80211req_key setkey;
|
|
struct ieee80211req_del_key delkey;
|
|
Index: madwifi-ng-r2568-20070710/tools/athstats.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/athstats.c 2007-07-23 01:48:38.886196167 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/athstats.c 2007-07-23 01:48:39.726244040 +0200
|
|
@@ -63,6 +63,10 @@
|
|
#include "wireless_copy.h"
|
|
#include "if_athioctl.h"
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
static const struct {
|
|
u_int phyerr;
|
|
const char* desc;
|
|
@@ -226,9 +230,20 @@
|
|
signalled = 1;
|
|
}
|
|
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+athstats_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
+
|
|
#ifdef __linux__
|
|
const char *ifname = "wifi0";
|
|
#else
|
|
Index: madwifi-ng-r2568-20070710/tools/do_multi.c
|
|
===================================================================
|
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
+++ madwifi-ng-r2568-20070710/tools/do_multi.c 2007-07-23 01:48:39.754245634 +0200
|
|
@@ -0,0 +1,30 @@
|
|
+#include <string.h>
|
|
+#include "do_multi.h"
|
|
+
|
|
+int
|
|
+main(int argc, char *argv[])
|
|
+{
|
|
+ char *progname;
|
|
+ int ret = 0;
|
|
+
|
|
+ progname = basename(argv[0]);
|
|
+
|
|
+ if(strcmp(progname, "80211debug") == 0)
|
|
+ ret = a80211debug_init(argc, argv);
|
|
+ if(strcmp(progname, "80211stats") == 0)
|
|
+ ret = a80211stats_init(argc, argv);
|
|
+ if(strcmp(progname, "athchans") == 0)
|
|
+ ret = athchans_init(argc, argv);
|
|
+ if(strcmp(progname, "athctrl") == 0)
|
|
+ ret = athctrl_init(argc, argv);
|
|
+ if(strcmp(progname, "athdebug") == 0)
|
|
+ ret = athdebug_init(argc, argv);
|
|
+ if(strcmp(progname, "athkey") == 0)
|
|
+ ret = athkey_init(argc, argv);
|
|
+ if(strcmp(progname, "athstats") == 0)
|
|
+ ret = athstats_init(argc, argv);
|
|
+ if(strcmp(progname, "wlanconfig") == 0)
|
|
+ ret = wlanconfig_init(argc, argv);
|
|
+
|
|
+ return ret;
|
|
+}
|
|
Index: madwifi-ng-r2568-20070710/tools/do_multi.h
|
|
===================================================================
|
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
|
+++ madwifi-ng-r2568-20070710/tools/do_multi.h 2007-07-23 01:48:39.778247001 +0200
|
|
@@ -0,0 +1,9 @@
|
|
+
|
|
+int a80211debug_init(int argc, char *argv[]);
|
|
+int a80211stats_init(int argc, char *argv[]);
|
|
+int athchans_init(int argc, char *argv[]);
|
|
+int athctrl_init(int argc, char *argv[]);
|
|
+int athdebug_init(int argc, char *argv[]);
|
|
+int athkey_init(int argc, char *argv[]);
|
|
+int athstats_init(int argc, char *argv[]);
|
|
+int wlanconfig_init(int argc, char *argv[]);
|
|
Index: madwifi-ng-r2568-20070710/tools/Makefile
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/Makefile 2007-07-23 01:48:38.902197078 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/Makefile 2007-07-23 01:48:39.798248141 +0200
|
|
@@ -49,6 +49,12 @@
|
|
|
|
ALL= athstats 80211stats athkey athchans athctrl \
|
|
athdebug 80211debug wlanconfig
|
|
+
|
|
+ifdef DOMULTI
|
|
+OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
|
|
+ athdebug.o 80211debug.o wlanconfig.o
|
|
+ALL= ${OBJS} madwifi_multi
|
|
+endif
|
|
|
|
all: $(ALL)
|
|
|
|
@@ -59,6 +65,30 @@
|
|
|
|
all: $(ALL)
|
|
|
|
+athstats.o: athstats.c
|
|
+ ${CC} -c -o athstats.o -DDOMULTI=1 ${ALL_CFLAGS} -I../ath athstats.c
|
|
+80211stats.o: 80211stats.c
|
|
+ ${CC} -c -o 80211stats.o -DDOMULTI=1 ${ALL_CFLAGS} 80211stats.c
|
|
+athkey.o: athkey.c
|
|
+ ${CC} -c -o athkey.o -DDOMULTI=1 ${ALL_CFLAGS} athkey.c
|
|
+athchans.o: athchans.c
|
|
+ ${CC} -c -o athchans.o -DDOMULTI=1 ${ALL_CFLAGS} athchans.c
|
|
+athctrl.o: athctrl.c
|
|
+ ${CC} -c -o athctrl.o -DDOMULTI=1 ${ALL_CFLAGS} athctrl.c
|
|
+athdebug.o: athdebug.c
|
|
+ ${CC} -c -o athdebug.o -DDOMULTI=1 ${ALL_CFLAGS} athdebug.c
|
|
+wlanconfig.o: wlanconfig.c
|
|
+ ${CC} -c -o wlanconfig.o -DDOMULTI=1 ${ALL_CFLAGS} wlanconfig.c
|
|
+80211debug.o: 80211debug.c
|
|
+ ${CC} -c -o 80211debug.o -DDOMULTI=1 ${ALL_CFLAGS} 80211debug.c
|
|
+do_multi.o: do_multi.c
|
|
+ ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
|
|
+madwifi_multi:
|
|
+ ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
|
|
+ for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
|
|
+ ln -s -f madwifi_multi $$i; \
|
|
+ done
|
|
+
|
|
athstats: athstats.c
|
|
$(CC) -o athstats $(ALL_CFLAGS) -I$(TOP)/ath $(LDFLAGS) athstats.c
|
|
80211stats: 80211stats.c
|
|
Index: madwifi-ng-r2568-20070710/tools/wlanconfig.c
|
|
===================================================================
|
|
--- madwifi-ng-r2568-20070710.orig/tools/wlanconfig.c 2007-07-23 01:48:38.910197536 +0200
|
|
+++ madwifi-ng-r2568-20070710/tools/wlanconfig.c 2007-07-23 01:48:39.850251108 +0200
|
|
@@ -62,6 +62,10 @@
|
|
#include "net80211/ieee80211_crypto.h"
|
|
#include "net80211/ieee80211_ioctl.h"
|
|
|
|
+#ifdef DOMULTI
|
|
+#include "do_multi.h"
|
|
+#endif
|
|
+
|
|
/*
|
|
* These are taken from ieee80211_node.h
|
|
*/
|
|
@@ -96,9 +100,19 @@
|
|
|
|
int verbose = 0;
|
|
|
|
+#ifdef DOMULTI
|
|
+
|
|
+int
|
|
+wlanconfig_init(int argc, char *argv[])
|
|
+{
|
|
+
|
|
+#else
|
|
+
|
|
int
|
|
main(int argc, char *argv[])
|
|
{
|
|
+
|
|
+#endif
|
|
const char *ifname, *cmd;
|
|
unsigned char bnounit = 0;
|
|
char *if_base = NULL;
|