1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-19 12:04:35 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.23/402-ledtrig_default_on.patch
nbd 00158ccffe "default-on" LED Trigger
The current LED subsystem always initialises LEDs in the OFF state. This is fine for most LEDs but some should be on right from boot (e.g. POWER LED). Following some discussion with the LED subsystem maintainers, a trigger was recommended as the best way to implement this functionality.

Here is a patch to add a new trigger "default-on" which will initialise an LED in the ON state. It is not compiled by default.

Particular thanks to Rod Whitby for all his help with this.

Signed-off-by: Nick Forbes <nick.forbes@incepta.com>


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10348 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-02-02 01:21:54 +00:00

24 lines
1.0 KiB
Diff

diff -ur linux-2.6.23.1.orig/drivers/leds/Kconfig linux-2.6.23.1/drivers/leds/Kconfig
--- linux-2.6.23.1.orig/drivers/leds/Kconfig 2007-12-01 00:41:03.000000000 +1300
+++ linux-2.6.23.1/drivers/leds/Kconfig 2007-12-01 01:26:43.000000000 +1300
@@ -137,4 +137,11 @@
tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS
+config LEDS_TRIGGER_DEFAULT_ON
+ tristate "LED Default ON Trigger"
+ depends on LEDS_TRIGGERS
+ help
+ This allows LEDs to be initialised in the ON state.
+ If unsure, say Y.
+
endif # NEW_LEDS
diff -ur linux-2.6.23.1.orig/drivers/leds/Makefile linux-2.6.23.1/drivers/leds/Makefile
--- linux-2.6.23.1.orig/drivers/leds/Makefile 2007-12-01 00:41:03.000000000 +1300
+++ linux-2.6.23.1/drivers/leds/Makefile 2007-12-01 01:27:12.000000000 +1300
@@ -23,3 +23,4 @@
obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o