mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-25 01:24:04 +02:00
29 lines
894 B
Diff
29 lines
894 B
Diff
--- a/drivers/video/Kconfig
|
|
+++ b/drivers/video/Kconfig
|
|
@@ -2148,6 +2148,15 @@ config FB_BROADSHEET
|
|
and could also have been called by other names when coupled with
|
|
a bridge adapter.
|
|
|
|
+config FB_JZ4740
|
|
+ tristate "JZ47420/JZ4740 LCD framebuffer support"
|
|
+ depends on FB
|
|
+ select FB_SYS_FILLRECT
|
|
+ select FB_SYS_COPYAREA
|
|
+ select FB_SYS_IMAGEBLIT
|
|
+ help
|
|
+ Framebuffer support for the JZ4720 and JZ4740 SoC.
|
|
+
|
|
source "drivers/video/omap/Kconfig"
|
|
|
|
source "drivers/video/backlight/Kconfig"
|
|
--- a/drivers/video/Makefile
|
|
+++ b/drivers/video/Makefile
|
|
@@ -126,6 +126,7 @@ obj-$(CONFIG_FB_OMAP) += oma
|
|
obj-$(CONFIG_XEN_FBDEV_FRONTEND) += xen-fbfront.o
|
|
obj-$(CONFIG_FB_CARMINE) += carminefb.o
|
|
obj-$(CONFIG_FB_MB862XX) += mb862xx/
|
|
+obj-$(CONFIG_FB_JZ4740) += jz4740_fb.o
|
|
|
|
# Platform or fallback drivers go here
|
|
obj-$(CONFIG_FB_UVESA) += uvesafb.o
|