mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:30:16 +02:00
dd21551c84
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26647 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
707 B
Diff
25 lines
707 B
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -65,6 +65,11 @@ config MTD_ROOTFS_SPLIT
|
|
depends on MTD_PARTITIONS
|
|
default y
|
|
|
|
+config MTD_TRXSPLIT
|
|
+ bool "Automatically find and split TRX partitions"
|
|
+ depends on MTD_PARTITIONS
|
|
+ default n
|
|
+
|
|
config MTD_REDBOOT_PARTS
|
|
tristate "RedBoot partition table parsing"
|
|
---help---
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -9,6 +9,7 @@ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.
|
|
mtd-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
|
|
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
|
|
+obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|