1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-08 11:46:43 +03:00
openwrt-xburst/package/uboot-envtools/patches/002-makefile.patch
thepeople 7226842ea8 this patch fixes uboot-envtools so that it is no longer broken.
-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19999 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-03-05 20:27:58 +00:00

37 lines
846 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -21,12 +21,10 @@
# MA 02111-1307 USA
#
-include $(TOPDIR)/config.mk
-
SRCS := $(obj)crc32.c fw_env.c fw_env_main.c
HEADERS := fw_env.h
-CPPFLAGS := -Wall -DUSE_HOSTCC -I$(SRCTREE)/include
+CPPFLAGS := -Wall $(CFLAGS)
ifeq ($(MTD_VERSION),old)
CPPFLAGS += -DMTD_OLD
@@ -35,18 +33,7 @@ endif
all: $(obj)fw_printenv
$(obj)fw_printenv: $(SRCS) $(HEADERS)
- $(CROSS_COMPILE)gcc $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
+ $(CC) $(CPPFLAGS) $(SRCS) -o $(obj)fw_printenv
clean:
rm -f $(obj)fw_printenv $(obj)crc32.c
-
-$(obj)crc32.c:
- ln -s $(src)../../lib_generic/crc32.c $(obj)crc32.c
-
-#########################################################################
-
-include $(TOPDIR)/rules.mk
-
-sinclude $(obj).depend
-
-#########################################################################