mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 17:11:34 +02:00
ae2566d99c
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12987 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
801 B
Diff
25 lines
801 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -77,6 +77,11 @@ config MVSWITCH_PHY
|
|
---help---
|
|
Currently supports the Marvell 88E6060 switch.
|
|
|
|
+config MICREL_PHY
|
|
+ tristate "Drivers for Micrel/Kendin PHYs"
|
|
+ ---help---
|
|
+ Currently has a driver for the KSZ8041
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -15,6 +15,7 @@ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
|
|
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
|
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_MICREL_PHY) += micrel.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|
|
obj-$(CONFIG_MDIO_OF_GPIO) += mdio-ofgpio.o
|