mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 15:37:29 +02:00
e0c1b38c1c
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12636 3c298f89-4303-0410-b956-a3cf2f4a3e73
15 lines
523 B
Diff
15 lines
523 B
Diff
Index: linux-2.6.21.7/Makefile
|
|
===================================================================
|
|
--- linux-2.6.21.7.orig/Makefile
|
|
+++ linux-2.6.21.7/Makefile
|
|
@@ -507,6 +507,9 @@ CFLAGS += $(call cc-option, -fn
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|