mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 15:37:29 +02:00
95571be1fb
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11302 3c298f89-4303-0410-b956-a3cf2f4a3e73
13 lines
359 B
Diff
13 lines
359 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -527,6 +527,9 @@
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|