1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-02 20:56:47 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.30/009-adm5120_leds_switch_trigger.patch
juhosg f34c09e21c [adm5120] add experimental support for 2.6.30
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15979 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-05-22 08:38:10 +00:00

23 lines
830 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -306,4 +306,12 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -40,3 +40,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o