1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-02 21:31:09 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.30/120-rb153_cf_driver.patch
juhosg f34c09e21c [adm5120] add experimental support for 2.6.30
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15979 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-05-22 08:38:10 +00:00

29 lines
878 B
Diff

--- a/drivers/ata/Makefile
+++ b/drivers/ata/Makefile
@@ -73,6 +73,7 @@ obj-$(CONFIG_PATA_OCTEON_CF) += pata_oct
obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o
obj-$(CONFIG_PATA_ICSIDE) += pata_icside.o
+obj-$(CONFIG_PATA_RB153_CF) += pata_rb153_cf.o
# Should be last but two libata driver
obj-$(CONFIG_PATA_ACPI) += pata_acpi.o
# Should be last but one libata driver
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -568,6 +568,15 @@ config PATA_RADISYS
If unsure, say N.
+config PATA_RB153_CF
+ tristate "RouterBOARD 153 Compact Flash support"
+ depends on ADM5120_MACH_RB_153
+ help
+ This option enables support for a Compact Flash connected on
+ the RouterBOARD 153.
+
+ If unsure, say N.
+
config PATA_RB532
tristate "RouterBoard 532 PATA CompactFlash support"
depends on MIKROTIK_RB532