1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-08 22:48:53 +03:00
openwrt-xburst/package/madwifi/patches/106-get_arch.patch
nbd b577ffc8a5 madwifi: remove the get_arch.mk build failure when the 'detected' arch doesn't match the build system's value
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17084 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-08-01 21:29:10 +00:00

22 lines
436 B
Diff

--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
$(Cannot determine ARCH)
endif
+# Allow ARCH to be x86
+ifneq (,$(CONFIG_X86))
+ifeq (x86,$(ARCH))
+ARCH-y = $(ARCH)
+endif
+endif
+
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)
-else
-ifneq ($(ARCH),$(ARCH-y))
-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
-endif
endif