1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-20 19:40:03 +03:00
openwrt-xburst/target/linux/ramips/patches-3.3/104-ramips-watchdog-driver.patch
juhosg 0f71b77a13 ramips: add support for 3.3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31403 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-04-21 12:30:50 +00:00

27 lines
762 B
Diff

--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -1033,6 +1033,13 @@ config LANTIQ_WDT
help
Hardware driver for the Lantiq SoC Watchdog Timer.
+config RAMIPS_WDT
+ tristate "Ralink RT288X/RT305X Watchdog Timer"
+ depends on (SOC_RT288X || SOC_RT305X || SOC_RT3883)
+ help
+ Hardware driver for the built-in watchdog timer on the
+ Ralink RT288X/RT305X SoCs.
+
# PARISC Architecture
# POWERPC Architecture
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -132,6 +132,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
+obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
# PARISC Architecture