1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-21 00:24:25 +03:00
openwrt-xburst/target/linux/rdc/patches-3.3/011-tune_lzma_options.patch
juhosg be6aa90ec2 rdc: add 3.3 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31530 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-04-29 15:59:49 +00:00

23 lines
745 B
Diff

--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
@@ -296,7 +296,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
quiet_cmd_lzma = LZMA $@
cmd_lzma = (cat $(filter-out FORCE,$^) | \
- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
(rm -f $@ ; false)
quiet_cmd_lzo = LZO $@
--- a/arch/x86/include/asm/boot.h
+++ b/arch/x86/include/asm/boot.h
@@ -28,7 +28,7 @@
#error "Invalid value for CONFIG_PHYSICAL_ALIGN"
#endif
-#ifdef CONFIG_KERNEL_BZIP2
+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
#define BOOT_HEAP_SIZE 0x400000
#else /* !CONFIG_KERNEL_BZIP2 */