mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:11:51 +02:00
b2cab73a78
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26691 3c298f89-4303-0410-b956-a3cf2f4a3e73
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
--- a/drivers/input/misc/Kconfig
|
|
+++ b/drivers/input/misc/Kconfig
|
|
@@ -467,4 +467,20 @@ config INPUT_XEN_KBDDEV_FRONTEND
|
|
To compile this driver as a module, choose M here: the
|
|
module will be called xen-kbdfront.
|
|
|
|
+config INPUT_GPIO_BUTTONS
|
|
+ tristate "Polled GPIO buttons interface"
|
|
+ depends on GENERIC_GPIO
|
|
+ select INPUT_POLLDEV
|
|
+ help
|
|
+ This driver implements support for buttons connected
|
|
+ to GPIO pins of various CPUs (and some other chips).
|
|
+
|
|
+ Say Y here if your device has buttons connected
|
|
+ directly to such GPIO pins. Your board-specific
|
|
+ setup logic must also provide a platform device,
|
|
+ with configuration data saying which GPIOs are used.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the
|
|
+ module will be called gpio-buttons.
|
|
+
|
|
endif
|
|
--- a/drivers/input/misc/Makefile
|
|
+++ b/drivers/input/misc/Makefile
|
|
@@ -44,4 +44,5 @@ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wist
|
|
obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
|
|
obj-$(CONFIG_INPUT_XEN_KBDDEV_FRONTEND) += xen-kbdfront.o
|
|
obj-$(CONFIG_INPUT_YEALINK) += yealink.o
|
|
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
|
|
|